Topic: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

I think I may have found an issue with DriverPacks and a certain nLite AddOn

Using this AddOn integrated with RVM Integrator v1.6.1b2.1:
http://www.wincert.net/forum/index.php? … build2716/

BUG: The below lines are removed from txtsetup.sif section [SourceDisksFiles] after DriverPacks:

UltraISO.CAB = 1,,,,,,_x,,3,3
UltraISO.inf = 1,,,,,,,20,0,0

Even did this SYSOC.Edit INF correction (see below) as suggested in AddOn forums by user Geej posted on 11/29/09, but issue still occured even after these changes:

[SYSOC.Edit]
%17%\sysoc.inf,Components,EZSystems=*

This all caused all INF installs to fail, Wordpad.exe and Calc.exe went missing. 
Adding back the 2 UltraISO entries into txtsetup.sif fixes issue.

So DriverPacks integration is removing UltraISO entries from txtsetup.sif for some reason.

Info:

Integrating into Windows XP Pro SP3 VLK
DriverPacks BASE 8.12.5, method 2, RunOnceEx
Also made sure to clear out QSC directory
Using the very latest x86 drivers packs for Windows XP as of 1/14/2010
no 3rd party driver packs
textmode driver packs integration along with all the other base ones (i.e. CPU, Chipset, Graphics, Audio, etc).

Here are sample files:
txtsetup.org
txtsetup.sif (after integration of driverpacks and I fixed and added back in the UltraISO entries)

Here is integration log:

2010-01-14 20:38:32 : <INIT> DriverPacks BASE 8.12.5 initialized.
2010-01-14 20:38:32 : <INIT> Host environment: WIN_XP Service Pack 3 on X86 CPU.
2010-01-14 20:38:32 : <INIT> Created temporary working directory.
2010-01-14 20:38:32 : <INIT> Imported proxy settings from Internet Explorer.
2010-01-14 20:38:32 : <INIT> Start scanning for DriverPacks for the wnt5_x86-32 platform.
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack Chipset 902!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack CPU 912!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack Graphics A 9121!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack Graphics B 912!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack Graphics C 912!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack LAN 8121!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack MassStorage 901!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack Sound A 805!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack Sound B 805!
2010-01-14 20:38:32 : <INIT> 	Detected DriverPack WLAN 806!
2010-01-14 20:38:32 : <INIT> 	Detected 3rd Party DriverPack Monitor 07111!
2010-01-14 20:38:32 : <INIT> 	Detected 3rd Party DriverPack PrintersCanonInkjet 61105!
2010-01-14 20:38:32 : <INIT> 	Detected 3rd Party DriverPack PrintersHP 71126!
2010-01-14 20:38:32 : <INIT> 	Detected 3rd Party DriverPack Scanner 60831!
2010-01-14 20:38:32 : <INIT> 	Finished scanning.
2010-01-14 20:38:32 : <INIT> Detected settings file "K:\00- Setup Builds\DriverPacks\DPs_BASE.ini".
2010-01-14 20:38:32 : <INIT> No OS could be detected.
2010-01-14 20:38:32 : <INIT> Imported settings from settings file.
2010-01-14 20:38:32 : <INIT> [Settings]\DPsMethod not specified: default (2) was set.
2010-01-14 20:38:32 : <INIT> [Settings]\finisherMethod not specified: default (GUIRunOnce) was set.
2010-01-14 20:38:32 : <INIT> [OptionalSettings]\KTD not specified: default (none) was set.
2010-01-14 20:38:32 : <INIT> [OptionalSettings]\QSC not specified: default (yes) was set.
2010-01-14 20:38:32 : <INIT> [OptionalSettingsOther]\ATI_cpl not specified: default (None) was set.
2010-01-14 20:38:32 : <INIT> [OptionalSettingsOther]\Nvidia_cpl not specified: default (None) was set.
2010-01-14 20:38:32 : <GUI>  Initialized GUI.
2010-01-14 20:38:32 : <GUI>  Created a list of all available language files.
2010-01-14 20:38:32 : <GUI>  Set the last used language, English, as the GUI language.
2010-01-14 20:39:12 : <GUI>  Changed Windows installation files OR export (depending on the installation platform) location to K:\00- Setup Builds\xpcd_pro_corp_patched_SP3_builds\b9- Final - nLite Removes then DriverPacks.
2010-01-14 20:39:12 : <GUI>  Windows XP Professional -  Retail SP3 detected.
2010-01-14 20:39:12 : <GUI>  wnt5_x86-32_disc is the selected installation platform .
2010-01-14 20:39:51 : <GUI>  Saved settings!
2010-01-14 20:39:51 : <GUI>  Closed GUI.
2010-01-14 20:39:51 : <SEL>  Selected module: mod_slip_wxp_x86-32_disc_m2.
2010-01-14 20:39:51 : <PREP> Removed all attributes from \I386.
2010-01-14 20:39:51 : <PREP> \I386\winnt.org was not found, \I386\winnt.sif was not restored.
2010-01-14 20:39:51 : <PREP> Neither txtsetup.org or dosnet.org was found. The removal of 
2010-01-14 20:39:51 : <PREP> any Service Packs we may have added with Driverpacks and or 
2010-01-14 20:39:51 : <PREP> removal of Mass Storage textmode drivers was skipped
2010-01-14 20:39:53 : <PREP> Verified method 2 references don't exist in txtsetup.sif or dosnet.inf.
2010-01-14 20:39:53 : <PREP> Cleaned up \$OEM$\cmdlines.txt.
2010-01-14 20:39:53 : <SLIP> QuickStream Cache available for DriverPack MassStorage text mode drivers!
2010-01-14 20:39:59 : <SLIP> Extracted DriverPack MassStorage to a temporary working directory.
2010-01-14 20:39:59 : <SLIP> K:\00- Setup Builds\DriverPacks\QSC\wnt5_x86-32_uni_DP_MassStorage_901_textmode\DriverPack_MassStorage_wnt5_x86-32.ini
2010-01-14 20:39:59 : <SLIP> Processing the files now. This may take a minute.
2010-01-14 20:40:11 : <SLIP> Slipstreamed DP MassStorage text mode drivers using QuickStream Cache.
2010-01-14 20:40:11 : <SLIP> txtsetup.sif Backed-up Successfully
2010-01-14 20:40:11 : <SLIP> dosnet.inf Backed-up Successfully
2010-01-14 20:40:13 : <SLIP> Removed entries from \I386\txtsetup.sif that will be updated.
2010-01-14 20:40:14 : <SLIP> Removed entries from \I386\dosnet.inf that will be updated.
2010-01-14 20:40:32 : <SLIP> Updated \I386\dosnet.inf and \I386\txtsetup.sif to support DP MassStorage text mode drivers.
2010-01-14 20:40:32 : <SLIP> Created necessary directory structure for method 2.
2010-01-14 20:40:32 : <SLIP> Copying files necessary for method 2.
2010-01-14 20:40:32 : <SLIP> Extracted additional files necessary for method 2.
2010-01-14 20:40:32 : <SLIP> expanded setup.ex_ to setuporg.exe
2010-01-14 20:40:32 : <SLIP> SETUP.EX_ Backed-up Successfully
2010-01-14 20:40:32 : <SLIP> Compressed setup.exe to SETUP.EX_.
2010-01-14 20:40:32 : <SLIP> Method 2 setup.ex_ installed
2010-01-14 20:40:32 : <SLIP> Created \I386\presetup.cmd file.
2010-01-14 20:40:32 : <SLIP> Updated \I386\txtsetup.sif to support method 2.
2010-01-14 20:40:32 : <SLIP> Updated \I386\dosnet.inf to support method 2.
2010-01-14 20:40:32 : <SLIP> Copied DriverPack Chipset to \OEM.
2010-01-14 20:40:32 : <SLIP> Copied DriverPack CPU to \OEM.
2010-01-14 20:40:37 : <SLIP> Copied DriverPack Graphics A to \OEM.
2010-01-14 20:40:40 : <SLIP> Copied DriverPack Graphics B to \OEM.
2010-01-14 20:40:44 : <SLIP> Copied DriverPack Graphics C to \OEM.
2010-01-14 20:40:44 : <SLIP> Copied DriverPack LAN to \OEM.
2010-01-14 20:40:44 : <SLIP> Copied DriverPack MassStorage to \OEM.
2010-01-14 20:40:46 : <SLIP> Copied DriverPack Sound A to \OEM.
2010-01-14 20:40:48 : <SLIP> Copied DriverPack Sound B to \OEM.
2010-01-14 20:40:49 : <SLIP> Copied DriverPack WLAN to \OEM.
2010-01-14 20:40:49 : <SLIP> Copied DriverPacks to \OEM.
2010-01-14 20:40:49 : <SLIP> Will not slipstream patches, Service Pack 3 was detected.
2010-01-14 20:40:49 : <SLIP> WINNT.SIF Backed-up Successfully
2010-01-14 20:40:49 : <SLIP> Updated \I386\winnt.sif to support method 2.
2010-01-14 20:40:49 : <SLIP> Updated DPsFnshr.ini to disable KTD.
2010-01-14 20:40:49 : <SLIP> Updated \$OEM$\cmdlines.txt to execute ROE.exe.
2010-01-14 20:40:49 : <SLIP> DP_Install_Tool was copied successfully
2010-01-14 20:40:49 : <SLIP> Slipstream finished in 59 seconds.
2010-01-14 20:43:58 : <CLNP> Temporary working directory successfully deleted.
- = DriverPacks BASE ini settings used = -
[General]
; preferred language
prefLang	= "English"
; yes/no, enable or disable the wizard-style buttons, if not specified: yes
wizardButtons	= "yes"
; yes/no, enable or disable the GUI, if not specified: yes
GUI		= "yes"


[Settings]
; disc/bartpe/multibootDisc
instPlatform	= "disc"
; trailing backslash is allowed, but not necessary
location	= "K:\00- Setup Builds\xpcd_pro_corp_patched_SP3_builds\b9- Final - nLite Removes then DriverPacks"
; none/all/select, if select, specify them below, if not specified: all
DriverPacks	= "select"
; 1/2, method to install the DriverPacks, if not specified: 2
DPsMethod	= "2"
; GUIRunOnce/RunOnceEx/custom, if not specified: GUIRunOnce
finisherMethod	= "RunOnceEx"


; you should only add this section if you've set [Settings]\finishMethod to "RunOnceEx"
[RunOnceExSettings]
; custom/default, if not specified: default
startID		= "default"


; this section is optional!
[OptionalSettings]
; none/all/select/paths/patterns, enable or disable Keep The Drivers (KTD) , if not specified: none
KTD		= "false"
; <path>, to specify a custom KTD cache location, if not specified: default (%SystemRoot%\DriverPacks)
KTDlocation	= "%SystemRoot%\DriverPacks"
; yes/no, enable or disable QuickStream Cache (QSC), if not specified: yes
QSC		= "yes"


; you should only add this section if you've set [Settings]\DriverPacks to "select"
[SelectDriverPacks]
DP_Chipset	= "yes"
DP_CPU		= "yes"
DP_Graphics_A	= "yes"
DP_Graphics_B	= "yes"
DP_Graphics_C	= "yes"
DP_LAN		= "yes"
DP_MassStorage	= "yes"
DP_Sound_A	= "yes"
DP_Sound_B	= "yes"
DP_WLAN		= "yes"
DPs_3rd_party	= "no"
DP_MassStorage_textmode = "yes"
2010-01-14 20:43:58 : <CLNP> Create a DPs_Base.log backup @ K:\00- Setup Builds\DriverPacks\LogFiles\DPs_BASE_10-01-14_20-43.log
2010-01-14 20:43:58 : <CLNP> Program terminated.

Let me know if you need any other info.

Last edited by jfcarbel (2010-01-15 17:38:56)

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

Most excellent first post! big_smile
Welcome to DriverPacks.
(I edited your thread title to better reflect the problem). wink
We're aware of this rare bug.  It was first reported here by dumpydooby.
Overflow is looking into it. 
The only solution we've found is the one you've already tried.  Integrate that single addon AFTER integrating DriverPacks.
Hopefully the fix will make it into the next version of DriverPacks BASE.

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

Wow... this is indeed a rare bug! reported here Dumpydooby's Report  at the bugtracker too.

I thought it was isolated to the certain file names dumpydooby reported... It seems it is not.

I am working on code this week so I'll switch gears and see if i can figure it out. Having two examples should make it MUCH easier to nail down!

Thanks for reporting it makes DriverPacks better for everyone! I second the motion... Outstanding first post!

Welcome to DriverPacks, we're glad your here.

Jeff

PS Feel free to Add a BUG report and reference DD's report. (there is a field for that.)

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

OK i have figured out HOW the problem occurs you and Dumpydooby are both victims of the exact same issue...

when we Replace an existing driver in the pack We must remove all entries related to that driver from the Dosnet and Txtsetup files...

A "replacement" is what we call it when we upgrade a driver that exists natively in windows....

UNFORTUNATLY we replace a driver called ULTRA

[P8]
ms_count=1
ms_1_deviceName="Promise SATAII150 TX2plus"
ms_1_tag="ultra"
ms_1_sysFile="ultra.sys"
ms_1_hwids="PCI\VEN_105A&DEV_4d33,PCI\VEN_105A&DEV_4D69,PCI\VEN_105A&DEV_4D68,PCI\VEN_105A&DEV_4D30&SUBSYS_4D33105A,PCI\VEN_105A&DEV_0D30&SUBSYS_4D33105A,PCI\VEN_105A&DEV_4D38&SUBSYS_4D33105A"
ms_1_isBusExtender=false
ms_1_exc_replaceIfOS="wxp,w2k3"

Notice the replaceIfOS tag wink

Now

Notice the lines that get deleted in your txtsetup.sif file (both of you) that are also very similar in name IE ultra*.*

ultradf3.cab = 100,,,,,,_x,,3,3
ultradf3.inf = 100,,,,,,,20,0,0
ultradfg.sif = 100,,,,,,_x,,3,3
ultradfg.sys = 100,,,,,,,4,0,0,,1,4
UltraISO.CAB = 1,,,,,,_x,,3,3
UltraISO.inf = 1,,,,,,,20,0,0
dfrg.exe = 100,,,,,,,2,0,0,ultradefrag.exe

Working on it now. I belive it has to do with nested quotation marks in the Fedit.exe routines

Obviously this only happens in 'ultra' rare cases. wink
IE Only if an addon Starts with same name as the replacement mass storage driver

So at least now I know:
How it happens.
What part of the code is doing it.
What triggers it.

I belive the problem is related to a really ugly set of nested quotes in a line similar to this

_runDos("""""" & @scriptDir & "\bin\Fedit.exe"" -rem -f """ & $_I386 & "\txtsetup.sif"" -s:c ""SourceDisksFiles"" -l:o """ & $NameOfDriverToReplace & """""")

working on a fix I will email you two for testing when I think i have it wink

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

@Overflow

Since you'll be releasing a new base, can you look into the problem I had before regarding the driver signing policy disabler?

Thanks in Advance...

I mean this:

http://forum.driverpacks.net/viewtopic. … 938#p29938

Last edited by Hectorfx (2010-01-19 13:29:42)

http://d1syubgj0w3cyv.cloudfront.net/cdn/farfuture/Av2BDsDf_iiqO8a4dpI49DKicUs_0zEQtEPcTGyCqV4/perpetual:forever/userbar/tester-1.png

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

Sure no problem... I'll take a good hard look at it...

I am not exactly sure how to attack that though... it looks like it worked 313 out of 314 times tongue sad.

Thanks a million for reminding me or I would certainly forgotten!

Have an awesome day!


PS fixed this bug in my testing copy - look forward to an email any day. I have to go through and make sure I have not broken anything in other changes i have made to the source.


Jeff

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

@Overflow

Thanks, once I'll receive it, I'll do a test on two machines plus on Dell Laptop.

http://d1syubgj0w3cyv.cloudfront.net/cdn/farfuture/Av2BDsDf_iiqO8a4dpI49DKicUs_0zEQtEPcTGyCqV4/perpetual:forever/userbar/tester-1.png

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

A Nightly version of BASE is up that should fix this issue big_smile

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [IMPL]DPBase removes UltraISO INF Addon from txtsetup.sif

Has this now been fixed in the official release versions of the Driver Packs?

UPDATE:
Yes, it has, just checked the release notes for the new DriverPacks BASE 10.06

DriverPacks BASE 10.06 release notes wrote:

- mass routine updated...

- Fix dumpydooby and jfcarbel issues with deleted txtsetup.sif entries
http://forum.driverpacks.net/viewtopic.php?id=3996
http://forum.driverpacks.net/viewtopic.php?id=4280

Thanks to all for fixing this!  Going to try it now in a build I am doing.

Last edited by jfcarbel (2010-06-20 11:04:48)