Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Updated to include Broadcom(WIDCOMM) Bluetooth Stack, see first post.

I used the same approach as the Toshiba Drivers. It was a lot easier than Toshiba, and hopefully it will work. wink

I used version to cover more hardware, the drivers used are located here: … MIGR-70450

If they don't work i can use that you linked to.

Hope they help, let us know how you go.


Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Yeah, I have made a mistake when I wrote this link smile
Thank you very much!!! smile

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Hi 7yler!

Sorry, but the Bluetooth Driver for Broadcom Bluetooth, from your new DP, not installed!
I think it's happened because a bluetooth radio was not be at "power-on" mode when installation process of this DP be at progress...
After logging on to Windows, Operating System has started searching a driver for my Broadcom Bluetooth device and not founded it. sad
HWID for my Bluetooth device: USB\Vid_0a5c&Pid_2110&Rev_0100

Last edited by Grunger86 (2008-10-22 12:38:42)

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Added, but USB\Vid_0a5c&Pid_2110&Rev_0100 should be covered by driver.

1. You need to have Bluetooth/WiFi hardware switch on for the Drivers to install.
2. If you have KTD enable and switch Bluetooth on after build, the Drivers will install but the Bluetooth Stack will not be installed.

Do a rebuild and let me know which driver gets installed, or (if any smile)

If installs, I will remove again because I don't think its needed.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Hello 7yler,
sorry, but I was wrong, the driver succesfully installed!

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Great, but which version?

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Removed DP_Bluetooth_wnt5_x86-32_081022.7z rolled back to DP_Bluetooth_wnt5_x86-32_081021.7z

Including both Broadcom Bluetooth Stacks ( and was not required.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Hi! smile

You should also include IVT BlueSoleil bluetooth stack. For example Clevo notebooks are using it. … uesoleil6x

I also get this error, with the latest Bluetooth pack:

Last edited by Skeptik (2008-10-25 08:51:15)

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

that may be the first screen shot i ever saw that was done with a camera... Nice!

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Hi Skeptik,

Thanks for the feedback, not sure why you would be getting that error. please check a few things:

* Make sure you are using DP_Bluetooth_wnt5_x86-32_081021.7z (Not DP_Bluetooth_wnt5_x86-32_081022.7z - this is no good)
* Post your HWID list
* Post your DP Finisher Log (DPsFnshr.log)

* Extract D\3\BT\B\BT5504300.exe from DP_Bluetooth_wnt5_x86-32_081021.7z and run it manually. See if that works, or errors.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

* Make sure you are using DP_Bluetooth_wnt5_x86-32_081021.7z (Not DP_Bluetooth_wnt5_x86-32_081022.7z - this is no good)
yes, I'm using the "DP_Bluetooth_wnt5_x86-32_081021.7z"

* Post your HWID list
here you are...

PCI Devices
PCI\VEN_10DE&DEV_0649&SUBSYS_003114C0&REV_A1\4&2DEFB0A9&0&0008: NVIDIA GeForce 9600M GT
PCI\VEN_10EC&DEV_8168&SUBSYS_003114C0&REV_02\4&3905AE0C&0&00E3: Realtek RTL8168C(P)/8111C(P) PCI-E Gigabit Ethernet NIC
PCI\VEN_197B&DEV_2381&SUBSYS_003114C0&REV_00\4&296E4DAC&0&02E4: JMB38X SD Host Controller
PCI\VEN_197B&DEV_2382&SUBSYS_003114C0&REV_00\4&296E4DAC&0&00E4: JMB38X SD/MMC Host Controller
PCI\VEN_197B&DEV_2383&SUBSYS_003114C0&REV_00\4&296E4DAC&0&03E4: JMB38X MS Host Controller
PCI\VEN_197B&DEV_2384&SUBSYS_003114C0&REV_00\4&296E4DAC&0&04E4: JMB38X xD Host Controller
PCI\VEN_8086&DEV_2448&SUBSYS_00000000&REV_93\3&11583659&0&F0: Intel(R) 82801 PCI Bridge - 2448
PCI\VEN_8086&DEV_2919&SUBSYS_00000000&REV_03\3&11583659&0&F8: Intel(R) ICH9M LPC Interface Controller - 2919
PCI\VEN_8086&DEV_2929&SUBSYS_003114C0&REV_03\3&11583659&0&FA: Intel(R) ICH9M-E/M SATA AHCI Controller
PCI\VEN_8086&DEV_2930&SUBSYS_003114C0&REV_03\3&11583659&0&FB: Intel(R) ICH9 Family SMBus Controller - 2930
PCI\VEN_8086&DEV_2934&SUBSYS_003114C0&REV_03\3&11583659&0&E8: Intel(R) ICH9 Family USB Universal Host Controller - 2934
PCI\VEN_8086&DEV_2935&SUBSYS_003114C0&REV_03\3&11583659&0&E9: Intel(R) ICH9 Family USB Universal Host Controller - 2935
PCI\VEN_8086&DEV_2936&SUBSYS_003114C0&REV_03\3&11583659&0&EA: Intel(R) ICH9 Family USB Universal Host Controller - 2936
PCI\VEN_8086&DEV_2937&SUBSYS_003114C0&REV_03\3&11583659&0&D0: Intel(R) ICH9 Family USB Universal Host Controller - 2937
PCI\VEN_8086&DEV_2938&SUBSYS_003114C0&REV_03\3&11583659&0&D1: Intel(R) ICH9 Family USB Universal Host Controller - 2938
PCI\VEN_8086&DEV_2939&SUBSYS_003114C0&REV_03\3&11583659&0&D2: Intel(R) ICH9 Family USB Universal Host Controller - 2939
PCI\VEN_8086&DEV_293A&SUBSYS_003114C0&REV_03\3&11583659&0&EF: Intel(R) ICH9 Family USB2 Enhanced Host Controller - 293A
PCI\VEN_8086&DEV_293C&SUBSYS_003114C0&REV_03\3&11583659&0&D7: Intel(R) ICH9 Family USB2 Enhanced Host Controller - 293C
PCI\VEN_8086&DEV_293E&SUBSYS_003114C0&REV_03\3&11583659&0&D8: Microsoft UAA Bus Driver for High Definition Audio
PCI\VEN_8086&DEV_2940&SUBSYS_00000000&REV_03\3&11583659&0&E0: Intel(R) ICH9 Family PCI Express Root Port 1 - 2940
PCI\VEN_8086&DEV_2942&SUBSYS_00000000&REV_03\3&11583659&0&E1: Intel(R) ICH9 Family PCI Express Root Port 2 - 2942
PCI\VEN_8086&DEV_2944&SUBSYS_00000000&REV_03\3&11583659&0&E2: Intel(R) ICH9 Family PCI Express Root Port 3 - 2944
PCI\VEN_8086&DEV_2946&SUBSYS_00000000&REV_03\3&11583659&0&E3: Intel(R) ICH9 Family PCI Express Root Port 4 - 2946
PCI\VEN_8086&DEV_2948&SUBSYS_00000000&REV_03\3&11583659&0&E4: Intel(R) ICH9 Family PCI Express Root Port 5 - 2948
PCI\VEN_8086&DEV_2A40&SUBSYS_00000000&REV_07\3&11583659&0&00: Mobile Intel(R) 4 Series Chipset Processor to DRAM Controller - 2A40
PCI\VEN_8086&DEV_2A41&SUBSYS_00000000&REV_07\3&11583659&0&08: Mobile Intel(R) 4 Series Chipset PCI Express Root Port - 2A41
PCI\VEN_8086&DEV_4232&SUBSYS_12018086&REV_00\4&492937F&0&00E2: Intel(R) WiFi Link 5100 AGN
27 matching device(s) found.

USB Devices
USB\ROOT_HUB\4&23F4E3F1&0                                   : USB Root Hub
USB\ROOT_HUB\4&2A80FBAA&0                                   : USB Root Hub
USB\ROOT_HUB\4&2D152E89&0                                   : USB Root Hub
USB\ROOT_HUB\4&3AE55D0&0                                    : USB Root Hub
USB\ROOT_HUB\4&6E9ACF5&0                                    : USB Root Hub
USB\ROOT_HUB\4&D3F5DCE&0                                    : USB Root Hub
USB\ROOT_HUB20\4&354A3B37&0                                 : USB Root Hub
USB\ROOT_HUB20\4&6246D00&0                                  : USB Root Hub
USB\VID_064E&PID_A115\CN2015-S30B-OV01-VS-R01.00.00         : USB Composite Device
USB\VID_064E&PID_A115&MI_00\6&32B5D4C4&0&0000               : USB Video Device
USB\VID_090C&PID_1000\AA04012700007748                      : USB Mass Storage Device
USB\VID_0A5C&PID_2151\001FE2F66617                          : Broadcom 2046 Bluetooth 2.1 USB Dongle
USB\VID_147E&PID_1000\5&3498DE22&0&2                        : TouchStrip Fingerprint Sensor
USBSTOR\DISK&VEN_CORSAIR&PROD_FLASH_VOYAGER&REV_1100\AA04012700007748&0: Corsair Flash Voyager USB Device
14 matching device(s) found.

Input Devices
No matching devices found.

ACPI Devices
ACPI\ACPI0003\4&FF861E6&0                                   : Microsoft AC Adapter
ACPI\CPL0002\2&DABA3FF&0                                    : COMPAL Embedded System Control
ACPI\FIXEDBUTTON\2&DABA3FF&0                                : ACPI Fixed Feature Button
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15\_0                : Intel(R) Pentium(R) Dual  CPU  T3200  @ 2.00GHz
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15\_1                : Intel(R) Pentium(R) Dual  CPU  T3200  @ 2.00GHz
ACPI\PNP0000\4&FF861E6&0                                    : Programmable interrupt controller
ACPI\PNP0100\4&FF861E6&0                                    : System timer
ACPI\PNP0103\4&FF861E6&0                                    : High Precision Event Timer
ACPI\PNP0200\4&FF861E6&0                                    : Direct memory access controller
ACPI\PNP0303\4&FF861E6&0                                    : Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
ACPI\PNP0A08\0                                              : PCI bus
ACPI\PNP0B00\4&FF861E6&0                                    : System CMOS/real time clock
ACPI\PNP0C02\1                                              : Motherboard resources
ACPI\PNP0C02\2                                              : Motherboard resources
ACPI\PNP0C04\4&FF861E6&0                                    : Numeric data processor
ACPI\PNP0C09\4&FF861E6&0                                    : Microsoft ACPI-Compliant Embedded Controller
ACPI\PNP0C0A\1                                              : Microsoft ACPI-Compliant Control Method Battery
ACPI\PNP0C0C\2&DABA3FF&0                                    : ACPI Power Button
ACPI\PNP0C0D\2&DABA3FF&0                                    : ACPI Lid
ACPI\SYN070B\4&FF861E6&0                                    : PS/2 Compatible Mouse
ACPI_HAL\PNP0C08\0                                          : Microsoft ACPI-Compliant System
ROOT\ACPI_HAL\0000                                          : ACPI Multiprocessor PC
22 matching device(s) found.

* Post your DP Finisher Log (DPsFnshr.log)
OK, a bit later then, because my installer does a cleanup after, including this file smile

* Extract D\3\BT\B\BT5504300.exe from DP_Bluetooth_wnt5_x86-32_081021.7z and run it manually. See if that works, or errors.
Manually installs without problems...

Last edited by Skeptik (2008-10-27 19:38:38)

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1


Ok. The HWID weren't really need as the installer is running smile

I dont think DPsFnshr.log would really be helpful either smile

The installer (BT5504300.exe) is causing the error, Reading the error "Adminstrator Error" it maybe a problem with your setup. wink

The only other thing I can think of is two installers (DP exceptions) are trying to run at the same time. I was having this problem with Toshiba Bluetooth.

You could try the following:

* Unpack DP_Bluetooth_wnt5_x86-32_081021.7z
* Edit DriverPack_Bluetooth_wnt5_x86-32.ini and change these lines:


exc_1_commands	= 1
exc_1_command1	= "%DPSROOT%\D\3\BT\B\BT5504300.exe"


exc_1_commands	= 3
exc_1_command1	= "PING -n 30 >NUL"
exc_1_command2	= "%DPSROOT%\D\3\BT\B\BT5504300.exe"
exc_1_command3	= "PING -n 30 >NUL"

* Compress DP_Bluetooth_wnt5_x86-32_081021.7z
* Retry and let us know how you go

This will put a large pause before and after the installer.

Good Luck.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

OK, but here is my DPsFnshr.log file anyway...

well.... I tried editing the INI file, but I get the same error message, as I posted above.

I have pretty basic unattended XP installation - haven't modified anything serious imho...

for example, anti-virus program and other stuff installs without problems at the RunOnceEx and I also have only one user account (built-in Administrator account)

Last edited by Skeptik (2008-10-27 22:52:02)

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Skeptik, thanks for your patience and testing out the Bluetooth Driverpacks.

I have redone the installer, which I hope will fix the error. smile

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

I get the same administrator privileges error with "DP_Bluetooth_wnt5_x86-32_81028" when Broadcom module installed sad

...and I tried this pack on ASUS notebook, where I have Toshiba bluetooth module installed. Everything installed correctly.

Last edited by Skeptik (2008-10-30 01:51:33)

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Skeptik, Thanks again for your feedback.

Its good to here that Toshiba Bluetooth is working for you smile

I not sure what to do about Broadcom Bluetooth, the problem is with the installer, but everything looks good from a packaging point of view. It would be good If someone else could confirm the problem, I might PM Grunger86 and see if he can test again.

Couple of things to check

* Check EventViewer and see if anything stands out as a problem (MSI version / errors / etc)
* Run installer after build has complete, and see if it errors, or installs and BT is working

If installer works after first loggon, as a workaround I could make it install as a RunOnce


Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Can the drivers for HP Laptops with Bluetooth be added ?

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

There were major problems with multiple bluetooth in one pack - there is a post about it around here somewhere...

it may be best to have seperate packs for BT - if you can get them to work together great! but i rmember that there was an issue when this was tried before...

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

The problem with Widcomm based bluetooth adapters is the licensing mechanism that they use.  It's a different install set for just about every vendor (and each chipset per vendor).  I know that there are "generic" Widcomm stacks out there, but the ones that are actually Widcomm code are more than likely not legal to distribute.

I started a Dell Bluetooth DP a while back to cover the various models that we use at my main job.  You would think that since they are all Widcomm that there would be a tremendous amount of statistical redundancy allowing for some crazy 7-Zip compression.  But sadly, this is not the case.  Having just four separate Dell models in one DP yields a .7z file close to 150MB.  Then of course is the trouble to make exception installers for all of these things <sigh>.

It would seem from what I have read here that adapters using the Toshiba stack seem to all work with the same install set (or am I missing something here?).  Unfortunately I think that so far as Widcomm goes, we're pretty much screwed.  You can quite easily make a DP consisting of the various .inf, .sys, and .cat files, but to get the full boat install would require a great deal more.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

Thanks RogueSpear,

Now things make sense. That explains why license.dat is required and the installer complains if it is not there, maybe a hardware vendor key.

Interestingly I can install it on a machine without Bluetooth hardware. Skeptik also confirmed it installed when running it manually, dont no what hardware, or if BT was working after the install.

Looks like I will have to remove the Widcomm drivers sad 

RogueSpear wrote:

It would seem from what I have read here that adapters using the Toshiba stack seem to all work with the same install set (or am I missing something here?).

Your not missing anything smile Toshiba Stack is straight from the link in the first post, the only change a AS.INI change to make it silent.

At least the Toshiba Stack looks to work well. The HWID for bluetooth in Toshiba notebooks is ACPI\TOS6205 (but they changed it for the lastest model I tested - USB\VID_....). Other vendors like ASUS also have HWIDs of USB\VID_.....

From what I can tell, the Toshiba Stack is generic and works for all vendors. Well at least no problems yet. smile

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

So it would seem making the BT drivers ala carte is the best thing...

That seems very doable
- each set
- or each individual driver (if neccessary)

in multiple packs. In this way a user cold select just the one or more packs they need.

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

I've got a bizare thing with a Lenovo T500. I can't enable/switch on bluetooth by pressing the classic way of "FN+F7" so I have to install a program "Lenovo Thinkvantage Access Connections" from Lenovo in order to enable BT. Can someone tell if you had this problem in the past and what you did to resolve this?

Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

You're bumping into a keyboard driver problem, not really a Bluetooth driver problem.

Lenove and a lot of Dells don't have full support for their keyboards in the BIOS.  This means that a driver (usually for function keys) needs to be loaded with Windows.

Complicating this (at least with Dells) is that there are multiple function key drivers, specific to different laptops.  It's a mess.

Nothing much to do for this except work out a way to get that driver loaded with your setup.


Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

It is Fn+F5 on all ThinkPads Fn+F7 is for presentation manager


Re: [REL] DP_Bluetooth_wnt5_x86-32_1005b1

The list of ThinkPad Fn keys is below … ecial_keys

The Fn keys just work by providing extra key scan codes ie. extra keys

The same software works across all ThinkPads

Hotkey Features is at  - … MIGR-68000

You do need drivers / software support in the Operating System. But this is the only real way to do it. It is easy to add, delete and change function in software but buggy and very difficult to change (and thus vendors won't) BIOS code much of which is very very old and written in assembly.