Topic: Problems with Mass Storage Driver for ICH9

I have been using chenalls DPMS batch file under grub4dos on a Oracle VirtualBox VM with the virtual hard disk configured as a VHD on an ICH9 controller. This makes a virtual F6 txtsetup.oem floppy disk in grub4dos.

The PCI ID for the AHCI controller appears in the VM as 8086 2829.

I think that the entry in the main wnt_x86_32.INI file for [I3] is incorrect as it refers to iastor3.sys.
However, the correct INF file for 8086_2829 is IAAHCI.inf (which is also in the I3 folder), and the correct sys file is iastor.sys not iastor3.sys.

I am not sure I fully understand the ini file syntax, but as the I3 folder contains 3 INF files, perhaps there should be separate entries for some PCI IDs.

I changed the I3 entry to be  tag=iastor and iastor.sys and now it works fine with DPMS.

Last edited by SteveSi (2013-06-26 05:40:25)

Re: Problems with Mass Storage Driver for ICH9

Welcome to DriverPacks.
You don't mention which dpms version you're using.

Read BEFORE you post.  HWID tool   DriverPacks Tutorial   DONATE!
Not all heroes wear capes, some wear Kevlar!

Re: Problems with Mass Storage Driver for ICH9

; version 12.09
decompSize    = 51131351                   
compSize    =  7801967               


Re: Problems with Mass Storage Driver for ICH9

You could try the latest nightly or Release Candidate for now.
[ReleaseCandidate] DP_MassStorage_wnt5_x86-32_1304-1305
They utilize {DriverVer=11/06/2010,} for that particular AHCI controller.  You will likely find that you need to edit the .Ini as you have previously noted.

The latest non-public (until now) nightly has VirtualBox support built-in via the "Red Hat, Inc. VirtIO SCSI Controller for VirtualBox" aka "viostor", yet it is thusfar untested in such an environment AFIK.  That HWID is "PCI\VEN_1AF4&DEV_1001&SUBSYS_00021AF4&REV_00".

Here, give it a go, if you like.  Note that i have not built a corresponding "D-P-M-S.iso" from it, nor do i have time to do so.  Also, there are other "Virty" bits included in the other two packs, thanks to dekdeck for providing the relevant link.

DP_Chipset_wnt5_x86-32_1306231.7z] - 7.06 MB   16eaae921836c63f88e4e1bae6c6a8d459677350
DP_MassStorage_wnt5_x86-32_1306202.7z - 9.18 MB   a9922b31453aec34d46bdea5eb5a916f4f03589c
DP_LAN_wnt5_x86-32_1306181.7z - 9.97 MB   f903139a98e175fa4d68918ae2b408009402e5ed

edit:  links removed.  updated via link above, etc.

If i understand the intent of Chenall's "D-P-M-S.iso", is that it is meant for NT5 install discs that do not have DriverPacks integrated with DP_BASE.  It is also out-of-date with the current nightlies.  I have updated it in step with the current RC.  You will find it at the bottom of the aforementioned post.  Your application of it is intriguing...

One question i would pose concerning VirtualBox, if i may, is what support is there for USB 3.0 controllers?
I know it would be handy for someone such as Damnation for testing NT5 installs from such controllers.

Also, could you please edit the name of this topic to indicate that it concerns a Virtual environment, not real hardware, so that readers are not possibly mislead.

Thank you for joining the forum!  Any feedback is appreciated.     smile

Last edited by TechDud (2013-06-26 09:58:25)

Re: Problems with Mass Storage Driver for ICH9

Thanks for the reply. the 1306202 build looks good! 8086 2829 has I9 = iastor.sys and it works!

re Chenalls D-P-M-S.iso - I have modified it so that it also adds in Firadisk and Winvblock.
This is for my Easy2Boot project (

So I can boot from a USB drive to grub4dos, mount a vanilla (unmodified) XP ISO, build an F6 disk using D-P-M-S.iso and then install XP directly from a USB drive. Easy2Boot can have any number of XP, Vista, 7,8,SVR2K8,SVR2012 ISOs on the drive and install from any of them.

For XP, the user needs to:
1. Boot from USB, choose XP ISO, press F6, add all drivers using S  (e.g. AHCI driver picked by D-P-M-S + Firadisk + WinVBlock drivers), then continue with text mode setup.
2. Reboot back to USB drive, load ISO into memory, boot from HDD - GUI mode setup begins.

re. Oracle. David B has written a utility which allows full rd/wr access to USB drives in an Oracle VBox VM. So now we can boot directly from a USB drive (incl. USB 3.0 adapters) on the host with full rd/wr access to the USB drive. This was not feasible previously as Windows locked the USB drive volume and prevented writes under the VM. … orkaround/

re. Name of this topic. It is nothing to do with a VM. merely that the INI file is incorrect and has the wrong sys driver for 8086 2829. The fact that I am testing on a VM is irrelevant. The Driver Pack is incorrect and it would affect a real ICHx controller as well as a VM. What happens is that you get an 'iastor.sys cannot be found' message during GUI mode setup, but XP seems to be able to use iastor3.sys just fine anyway!

Last edited by SteveSi (2013-06-26 10:21:40)

Re: Problems with Mass Storage Driver for ICH9

Please post your modified "Chenall's D-P-M-S.iso".

To Admin:  perhaps this thread deserves a sticky?

Re: Problems with Mass Storage Driver for ICH9

It is not a modified D-P-M-S. iso, it is just flat files. the d-pms.bat has been re-written for Easy2Boot.

The download is on my blog … sting.html

To make it work from grub4dos you would need to use
set FIRA=2
/d-pms.bat 0  (remove hyphen!)

You also need a D-PMS\FIRA folder to hold the FiraDisk and WinVBlock files (see the download for more details).
Please bear in mind that this is a very new development and is not yet fully tested!

Last edited by SteveSi (2013-06-26 10:47:57)

Re: Problems with Mass Storage Driver for ICH9

I spoke too soon! The 1306202 build BSODs in GUI-Mode setup at just after 34 minutes point with 0x000000F4 error!  Xp Sp3Pro. This is using the files.
At least the version 12.09 didn't BSOD!

Re: Problems with Mass Storage Driver for ICH9

Testing within a VM will always have pitfalls with drivers because the hardware is not always presented to the virtual environment in the correct way.
One way to isolate the VM as the source of the problem is to try your build on a live-metal machine using a spare HDD (all other HDD disconnected).
If it works on live-metal but crashes in VM then you know the source of the problem.

In my opinion, VMware is a much better VM than VirtualBox.  I used to use VB exclusively but eventually moved to VMware for speed/compatibility.
When building DriverPacks releases, I always test in VM first but test installs on live-metal as a final check.  To say dpms is "incorrect" is not true, my older tower system had a 2829 HWID and it worked fine with dpms 1209 before I sold it.

You're using DriverPacks in an unsupported way.  We're in uncharted waters here, so be patient with us. smile

Read BEFORE you post.  HWID tool   DriverPacks Tutorial   DONATE!
Not all heroes wear capes, some wear Kevlar!

Re: Problems with Mass Storage Driver for ICH9

Well 12.09 worked in VBox (in that it did not BSOD - it just requested iastor.sys during phase 2).
I know what you are saying about a real machine, but I don't have one at the moment with ICH9 8086_2829.

Is there a description of the DriverPacks.ini syntax anywhere?

For instance,  the section below is for folder I3 in 12.09 which has 3 inf files
2829 is only present in iaahci.inf which uses iastor.inf and iastor.sys

So why is the 2829 PCI ID listed in this section for iastor3 and not iastor.sys?

ms_1_deviceName="Intel ICH8/ICH9/EP 80579 SATA AHCI/RAID Matrix 7.8"


Re: Problems with Mass Storage Driver for ICH9

Well, the .ini reference for dpms is included in the DriverPacks BASE download. 
We do have an online reference for modifying the dpms and it can be found here: … assstorage

Just for reference, the .ini is only used to manipulate the txtsetup phase (first blue setup screen) in conjunction with DriverPacks BASE.  It's primary job is to allow DriverPacks BASE to modify the txtsetup.sif file correctly.  It also ensures that the .sys files are named properly (xxxxxxxx.yyy 8.3 method), It has nothing to do with how the "phase 2" portion (T-39 thru T-0 minutes) proceeds.
The .ini is only processed during a normal DriverPacks BASE integration or in tandem with the BartPE plugin.  The .ini is ignored during all phases of install and by DriverPacks Finisher.

Your setup doesn't seem to utilize the updated .ini in favor of it's own.  That may be your problem.

Just to isolate this further, can you do a "normal" DriverPacks BASE integration with a clean XP source and see if that has the same problem in your VM?

Nice project you have at

Read BEFORE you post.  HWID tool   DriverPacks Tutorial   DONATE!
Not all heroes wear capes, some wear Kevlar!

Re: Problems with Mass Storage Driver for ICH9

SteveSi wrote:

driver for 8086 2829. The fact that I am testing on a VM is irrelevant.

Well, there is a history at VirtualBox 8086 2829.
Newer iastor driver version failed in the past, appearantly Intel dosn't support a VirtualBox device officially. … d-drivers/
Back then iastor.sys 7.8 is recommended for a VirtualBox 8086 2829.
Newer Intel drivers works at real Intel hardware 8086 2829.

Re: Problems with Mass Storage Driver for ICH9

One additional note; PCI\VEN_8086&DEV_2829&CC_0106
is actually Intel® ICH8M SATA AHCI Controller - 2829
aka    82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode]

Textmode operation verified personally on an Inspiron 1525.