Topic: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks


Forgive me if this isn't the correct forum for this post.

I'm finding a BSOD after installing XP SP3  using the latest driverpacks. Interestingly I've installed onto the same system(s) using older packs without issue.

I have removed my customized answer file and own scripts and resorted to using a clean XP source rather than a RVM'd one with some of the updates slipstreamed built in.

I ran the HWIDs tool:

PCI Devices 
PCI\VEN_14E4&DEV_169B&SUBSYS_02201028&REV_02\4&117729E2&0&00E0: Broadcom NetXtreme 57xx Gigabit Controller
PCI\VEN_8086&DEV_244E&SUBSYS_00000000&REV_E1\3&172E68DD&0&F0: Intel(R) 82801 PCI Bridge - 244E
PCI\VEN_8086&DEV_27B8&SUBSYS_00000000&REV_01\3&172E68DD&0&F8: Intel(R) ICH7 Family LPC Interface Controller - 27B8
PCI\VEN_8086&DEV_27C1&SUBSYS_02201028&REV_01\3&172E68DD&0&FA: Intel(R) ICH7R/DH SATA AHCI Controller
PCI\VEN_8086&DEV_27C8&SUBSYS_02201028&REV_01\3&172E68DD&0&E8: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27C8
PCI\VEN_8086&DEV_27C9&SUBSYS_02201028&REV_01\3&172E68DD&0&E9: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27C9
PCI\VEN_8086&DEV_27CA&SUBSYS_02201028&REV_01\3&172E68DD&0&EA: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27CA
PCI\VEN_8086&DEV_27CB&SUBSYS_02201028&REV_01\3&172E68DD&0&EB: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27CB
PCI\VEN_8086&DEV_27CC&SUBSYS_02201028&REV_01\3&172E68DD&0&EF: Intel(R) N10/ICH7 Family USB2 Enhanced Host Controller - 27CC
PCI\VEN_8086&DEV_27D0&SUBSYS_00000000&REV_01\3&172E68DD&0&E0: Intel(R) N10/ICH7 Family PCI Express Root Port - 27D0
PCI\VEN_8086&DEV_27D8&SUBSYS_02201028&REV_01\3&172E68DD&0&D8: Microsoft UAA Bus Driver for High Definition Audio
PCI\VEN_8086&DEV_27DA&SUBSYS_02201028&REV_01\3&172E68DD&0&FB: Intel(R) N10/ICH7 Family SMBus Controller - 27DA
PCI\VEN_8086&DEV_27DF&SUBSYS_02201028&REV_01\3&172E68DD&0&F9: Intel(R) ICH7 Family Ultra ATA Storage Controllers - 27DF
PCI\VEN_8086&DEV_29C0&SUBSYS_00000000&REV_0A\3&172E68DD&0&00: Intel(R) G33/G31/P35/P31 Express Chipset Processor to I/O Controller - 29C0
PCI\VEN_8086&DEV_29C1&SUBSYS_00000000&REV_0A\3&172E68DD&0&08: Intel(R) G33/G31/P35/P31 Express Chipset PCI Express Root Port - 29C1
PCI\VEN_8086&DEV_29C2&SUBSYS_02201028&REV_0A\3&172E68DD&0&10: Intel(R) G33/G31 Express Chipset Family
PCI\VEN_8086&DEV_29C3&SUBSYS_02201028&REV_0A\3&172E68DD&0&11: Intel(R) G33/G31 Express Chipset Family
17 matching device(s) found.
USB Devices 
USB\ROOT_HUB\4&2032E073&0                                   : USB Root Hub
USB\ROOT_HUB\4&35A228E6&0                                   : USB Root Hub
USB\ROOT_HUB\4&6727943&0                                    : USB Root Hub
USB\ROOT_HUB\4&EFCCF30&0                                    : USB Root Hub
USB\ROOT_HUB20\4&27D9CFBB&0                                 : USB Root Hub
USB\VID_03F9&PID_0100\6&1DF626FD&0&2                        : Key Tronic USB Keyboard
USB\VID_0424&PID_2504\5&425E0F2&0&2                         : Generic USB Hub
USB\VID_045E&PID_0040\6&1DF626FD&0&1                        : Microsoft USB Wheel Mouse Optical
USB\VID_067B&PID_2528\0007090723CA262DA604                  : USB Mass Storage Device
USBSTOR\DISK&VEN_USB_2.0&PROD_FLASH_DISK&REV_1.00\0007090723CA262DA604&0: Disk drive
10 matching device(s) found.
Input Devices 
HID\VID_03F9&PID_0100\7&2961A306&0&0000                     : Key Tronic USB Keyboard
HID\VID_045E&PID_0040\7&588A4F2&0&0000                      : Microsoft USB Wheel Mouse Optical (IntelliPoint)
2 matching device(s) found.
ACPI Devices 
ACPI\FIXEDBUTTON\2&DABA3FF&0                                : ACPI Fixed Feature Button
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15\_0                : Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15\_1                : Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
ACPI\PNP0000\4&E5ACEE3&0                                    : Programmable interrupt controller
ACPI\PNP0100\4&E5ACEE3&0                                    : System timer
ACPI\PNP0103\2&DABA3FF&0                                    : High Precision Event Timer
ACPI\PNP0200\4&E5ACEE3&0                                    : Direct memory access controller
ACPI\PNP0401\4&E5ACEE3&0                                    : ECP Printer Port (LPT1)
ACPI\PNP0501\1                                              : Communications Port (COM1)
ACPI\PNP0800\4&E5ACEE3&0                                    : System speaker
ACPI\PNP0A03\4                                              : PCI bus
ACPI\PNP0B00\4&E5ACEE3&0                                    : System CMOS/real time clock
ACPI\PNP0C01\B                                              : System board
ACPI\PNP0C04\4&E5ACEE3&0                                    : Numeric data processor
ACPI\PNP0C0C\2&DABA3FF&0                                    : ACPI Power Button
ACPI_HAL\PNP0C08\0                                          : Microsoft ACPI-Compliant System
ROOT\ACPI_HAL\0000                                          : ACPI Multiprocessor PC
17 matching device(s) found.
 HDA Audio 
HDAUDIO\FUNC_01&VEN_11D4&DEV_1984&SUBSYS_10280220&REV_1004\4&4B9D1C0&0&0001: SoundMAX Integrated Digital HD Audio Device
1 matching device(s) found.
RAID Devices 
    Name: Intel(R) ICH7R/DH SATA AHCI Controller
    Hardware ID's:
    Compatible ID's:
    Name: Intel(R) ICH7 Family Ultra ATA Storage Controllers - 27DF
    Hardware ID's:
    Compatible ID's:
2 matching device(s) found.

The BSOD STOP error is:
STOP: 0x0000007B

The BSOD occurs even in safemode. I'm fairly certain of the HDD's and RAM modules health.

The driverpacks in use are:


With 3rd party ones:


I'm using DPs_BASE.exe version 1006 and disabled QSC.
(Ignore the folder name indicating RVM the actual contents used were clean vol license XP SP3 source and no customizations made at all.)
The configuration is:

; preferred language
prefLang	= "English"
; yes/no, enable or disable the wizard-style buttons, if not specified: yes
wizardButtons	= "yes"
; yes/no, enable or disable the GUI, if not specified: yes
GUI		= "yes"

; disc/bartpe/multibootDisc
instPlatform	= "disc"
; trailing backslash is allowed, but not necessary
location	= "S:\SlipStream\3-DriverPack'd\SSXPProVolSP3CD_3_(RVM'd)_DriverPack'd"
; none/all/select, if select, specify them below, if not specified: all
DriverPacks	= "all"
; 1/2, method to install the DriverPacks, if not specified: 2
DPsMethod	= "2"
; GUIRunOnce/RunOnceEx/custom, if not specified: GUIRunOnce
finisherMethod	= "GUIRunOnce"

; this section is optional!
; none/all/select/paths/patterns, enable or disable Keep The Drivers (KTD) , if not specified: none
KTD		= "all"
; <path>, to specify a custom KTD cache location, if not specified: default (%SystemRoot%\DriverPacks)
KTDlocation	= "%SystemRoot%\DriverPacks"
; yes/no, enable or disable QuickStream Cache (QSC), if not specified: yes
QSC		= "no"

Does anyone have any suggestions or can anyone spot anything wrong that I'm doing wrong?

Best Wishes

Re: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks

I would remove the Third Party DriverPacks and try again. 
It's definitely possible you're being hit with this bug:

Re: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks

Hello again.
  mr_smartepants' conclusion is most likely the correct one.
The webcam, HID & Monitor packs are probably the worst for path length.

If removing the 3rd Party packs doesn't resolve this, i have a couple of questions to ask.

Does RAID work with the Optiplex 330 & DP_MassStorage_wnt5_x86-32_1209.7z ?
I note that you stated that an older pack worked previously.  Which older pack worked?

If the problem was simply path length, then please disregard.

Last edited by TechDud (2013-06-20 21:37:16)

Re: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks

Thank you Chaps.

I'll try a slimmed down version with no 3rd party driver packs. If that works I'll look at SAD'ing them and getting them that way.

RAID is an option in the OptiPlex 330. We don't use it. I think the BIOS has it set to AUTO/AHCI rather than AUTO/ATA. I don't see a section to change the drive operation from ATA to AHCI or vice versa other than the RAID setting. So I left it alone I would like AHCI if possible.

I'm sorry I can't recall exactly which older version worked. My sequence of events was:
* Last working on OptiPlex's (380's)
* Update all driver packs.
* Notice issue with OptiPlex 3010's.
* Update MassStorage and Chipset to beta packs rc2 to try and troubleshoot OptiPlex 3010 issues.
* A few months later realize CD doesn't work on OptiPlex 330's.
* Update all driver packs and remove beta packs.

Unfortunately I am simply not sure what the prior version(s) of the driver packs were. Assuming they are easy to find (I'm sure they are), I may roll back one pack version at a time for chipset and mass storage and if stuck.

Thank you for your help.

Re: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks

I don't want to send you on a "wild goose chase".

It is an apt conclusion that removing those 3rd Party packs will solve the issue you have experienced, as mr_smartepants has rightfully stated.

That being said, i can say that the last time that HWID changed was in DP_MassStorage_wnt5_x86-32_1203, if i remember correctly.  That should be a good starting point should things not work out as expected.  I note that the current RC & Nightly utilizes the same v11.2 driver as DP_MassStorage_wnt5_x86-32_1209 & 1206 at the very least.  Testing RAID can offer a "differential diagnosis" of sorts, if and only if path length was not of issue.  In addition, i would note that dell offers v7.8 for download for that hardware.

I have learned the hard lesson of second-guessing mr_smartepants' prevous work.  That usually involves failure.

I appreciate any input you can deliver concerning any NT5 DriverPack.

Last edited by TechDud (2013-06-21 04:12:44)

Re: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks

mr_smartepants was indeed spot on. I removed 3rd party driver packs and changed nothing else. Install and setup went like a dream. There was no need to drop back to "clean" non-customized versions or older packs. The latest packs do work fine so long as I leave 3rd party driver packs out of initial inclusion.

I will stick with this as an approach. I now include a SAD3 folder (StandAloneDrivers 3rd party) onto the ISO and will reference the install .cmd with a runonce command.

It is a weight off my mind. The driverpacked CD now installs, configures profile via script, installs 3rd party driver packs, then updates windows via a WSUSoffline network share then installs and updates 3rd party programs. Thanks to driver packs I have a baseline "fire and forget" solution for most platforms.

Had mr_smartepants and you not have helped resolve this I would likely have been stuck for a good while. Thank you.

Best Wishes

Last edited by MattyUSA (2013-06-25 06:23:36)

Re: [SLVD] Dell Optiplex 330 XP32b BSOD Latest DriverPacks

Glad you got it sorted out.
A couple of notes to help you out:
You should remove DP_LAN-RIS_wnt5_x86-32_1011.7z it is not needed (nor desirable).  It's intended specifically for RIS-server deployments (non-desktop builds).

We encourage you to include the following optional Third Party DriverPacks in your build since the DPsFnshr.ini will utilize these only if present.
DP_Graphics_Languages_wnt5_x86-32_1206.7z (only needed for non-English installs)
DP_Graphics_PhysX_wnt5_x86-32_1206.7z (only for matching nvidia hardware)
DP_Runtimes_wnt5_x86-32_1206.7z (only for ATI graphics cards)