Topic: [SLVD] Not able to setup windows

Hi mr_smartepants, first off thanks for all the great work you do, it seems to go unthanked far too much.

I'm struggling to load windows on a SATA drive.  But may be its just bust...

I made a new cd with

DriverPack Chipset 1201!
DriverPack Graphics A 1107!
DriverPack Graphics B 1107!
DriverPack Graphics C 1107!
DriverPack LAN 1202!
DriverPack Mass Storage 1201!
DriverPack Sound A 1111!
DriverPack Sound B 1111!
DriverPack WLAN 1202!
3rd Party DriverPack HID 1109r1!
3rd Party DriverPack Misc 1201!
3rd Party DriverPack WebCam 1107!

Which works fine using a PATA hardisk, but behaves very odd with the SATA drive I want to use on the same hardware.  If I remove the PATA disc from system and plug in the SATA drive the whole PC goes on a go slow.  It even takes ages to get into the BIOS.  Here it shows the harddisc but loading windows isn't working, eventually I get to the bit where Windows tries to install but then I get [setup cannot access this disc] and if you press enter it blue sceens with.  Any thoughts?

STOP: 0x0000008E (0C0000005, 0XF7419CAD, 0X797A7E4,0X00000000)

PCI Devices 
PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458&REV_02\4&3A0400F3&0&00E1: Realtek PCIe GBE Family Controller
PCI\VEN_8086&DEV_244E&SUBSYS_00000000&REV_E1\3&13C0B0C5&0&F0: Intel(R) 82801 PCI Bridge - 244E
PCI\VEN_8086&DEV_2770&SUBSYS_00000000&REV_02\3&13C0B0C5&0&00: Intel(R) 945G/GZ/GC/P/PL Processor to I/O Controller - 2770
PCI\VEN_8086&DEV_2772&SUBSYS_D0001458&REV_02\3&13C0B0C5&0&10: Intel(R) 82945G Express Chipset Family
PCI\VEN_8086&DEV_27B8&SUBSYS_00000000&REV_01\3&13C0B0C5&0&F8: Intel(R) ICH7 Family LPC Interface Controller - 27B8
PCI\VEN_8086&DEV_27C0&SUBSYS_B0021458&REV_01\3&13C0B0C5&0&FA: Intel(R) N10/ICH7 Family Serial ATA Storage Controller - 27C0
PCI\VEN_8086&DEV_27C8&SUBSYS_50041458&REV_01\3&13C0B0C5&0&E8: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27C8
PCI\VEN_8086&DEV_27C9&SUBSYS_50041458&REV_01\3&13C0B0C5&0&E9: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27C9
PCI\VEN_8086&DEV_27CA&SUBSYS_50041458&REV_01\3&13C0B0C5&0&EA: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27CA
PCI\VEN_8086&DEV_27CB&SUBSYS_50041458&REV_01\3&13C0B0C5&0&EB: Intel(R) N10/ICH7 Family USB Universal Host Controller - 27CB
PCI\VEN_8086&DEV_27CC&SUBSYS_50061458&REV_01\3&13C0B0C5&0&EF: Intel(R) N10/ICH7 Family USB2 Enhanced Host Controller - 27CC
PCI\VEN_8086&DEV_27D0&SUBSYS_00000000&REV_01\3&13C0B0C5&0&E0: Intel(R) N10/ICH7 Family PCI Express Root Port - 27D0
PCI\VEN_8086&DEV_27D2&SUBSYS_00000000&REV_01\3&13C0B0C5&0&E1: Intel(R) N10/ICH7 Family PCI Express Root Port - 27D2
PCI\VEN_8086&DEV_27D8&SUBSYS_A0021458&REV_01\3&13C0B0C5&0&D8: Microsoft UAA Bus Driver for High Definition Audio
PCI\VEN_8086&DEV_27DA&SUBSYS_50011458&REV_01\3&13C0B0C5&0&FB: Intel(R) N10/ICH7 Family SMBus Controller - 27DA
PCI\VEN_8086&DEV_27DF&SUBSYS_B0011458&REV_01\3&13C0B0C5&0&F9: Intel(R) ICH7 Family Ultra ATA Storage Controllers - 27DF
16 matching device(s) found.
USB Devices 
USB\ROOT_HUB\4&10C3B2A4&0                                   : USB Root Hub
USB\ROOT_HUB\4&26FCA6D4&0                                   : USB Root Hub
USB\ROOT_HUB\4&37690C5A&0                                   : USB Root Hub
USB\ROOT_HUB\4&574D1E&0                                     : USB Root Hub
USB\ROOT_HUB20\4&172B99F8&0                                 : USB Root Hub
USB\VID_045E&PID_0040\5&50ADEA6&0&1                         : Microsoft USB Wheel Mouse Optical
USB\VID_0781&PID_5567\11013213D9E274A4                      : USB Mass Storage Device
USBSTOR\DISK&VEN_SANDISK&PROD_CRUZER_BLADE&REV_8.02\11013213D9E274A4&0: SanDisk Cruzer Blade USB Device
8 matching device(s) found.
Input Devices 
HID\VID_045E&PID_0040\6&2D837293&0&0000                     : Microsoft USB Wheel Mouse Optical (IntelliPoint)
1 matching device(s) found.
ACPI Devices 
ACPI\FIXEDBUTTON\2&DABA3FF&0                                : ACPI Fixed Feature Button
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_23\_0                : Intel(R) Core(TM)2 Duo CPU     E7200  @ 2.53GHz
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_23\_1                : Intel(R) Core(TM)2 Duo CPU     E7200  @ 2.53GHz
ACPI\INT0800\2&DABA3FF&0                                    : Intel(R) 82802 Firmware Hub Device
ACPI\PNP0000\4&2D88FB92&0                                   : Programmable interrupt controller
ACPI\PNP0100\4&2D88FB92&0                                   : System timer
ACPI\PNP0200\4&2D88FB92&0                                   : Direct memory access controller
ACPI\PNP0303\4&2D88FB92&0                                   : PS/2 Keyboard (106 Keys Ctrl+Caps)
ACPI\PNP0400\4&2D88FB92&0                                   : Printer Port (LPT1)
ACPI\PNP0501\1                                              : Communications Port (COM1)
ACPI\PNP0700\4&2D88FB92&0                                   : Standard floppy disk controller
ACPI\PNP0800\4&2D88FB92&0                                   : System speaker
ACPI\PNP0A03\1                                              : PCI bus
ACPI\PNP0B00\4&2D88FB92&0                                   : System CMOS/real time clock
ACPI\PNP0C01\2&DABA3FF&0                                    : System board
ACPI\PNP0C02\1                                              : Motherboard resources
ACPI\PNP0C02\2                                              : Motherboard resources
ACPI\PNP0C02\4                                              : Motherboard resources
ACPI\PNP0C04\4&2D88FB92&0                                   : Numeric data processor
ACPI\PNP0C0C\2&DABA3FF&0                                    : ACPI Power Button
ACPI_HAL\PNP0C08\0                                          : Microsoft ACPI-Compliant System
ROOT\ACPI_HAL\0000                                          : ACPI Multiprocessor PC
22 matching device(s) found.
 HDA Audio 
HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1458A002&REV_1001\4&2F790C35&0&0201: Realtek High Definition Audio
1 matching device(s) found.
RAID Devices 
    Name: Intel(R) N10/ICH7 Family Serial ATA Storage Controller - 27C0
    Hardware ID's:
    Compatible ID's:
    Name: Intel(R) ICH7 Family Ultra ATA Storage Controllers - 27DF
    Hardware ID's:
    Compatible ID's:
2 matching device(s) found.

Re: [SLVD] Not able to setup windows

Are you sure the drive is OK?  Because it's SATA, you can connect it natively to another PC for testing (I prefer SpinRite).
Once you're sure the drive itself is OK, check the BIOS to make sure the SATA ports are not in "legacy" or "IDE" mode but the preferred "AHCI" mode.
This HWID indicates that you have it in "legacy" mode and no textmode drivers are needed.  Once you change the mode to "AHCI" or "RAID", the HWID should change to PCI\VEN_8086&DEV_27C*&CC_0104 or PCI\VEN_8086&DEV_27C*&CC_0106

Read BEFORE you post.  HWID tool   DriverPacks Tutorial   DONATE!
Not all heroes wear capes, some wear Kevlar!

Re: [SLVD] Not able to setup windows

I think the drives messed up.  I can't get it to behave on any PC.  I'll come back when I get hold of another to test.

sorry to use up your time...

Re: [SLVD] Not able to setup windows

If you decide to attempt to revive that 'bad' drive, here's some recommendations.

Visit the drive manufacturer's site (& the system/mobo OEM's site)  to check for firmware updates for the drive. Make note of whether or not your drive can use 4k sectors (& jumper settings, if applicable).  While you're there check the Warranty remaining.

Ensure that LBA is selected in BIOS.  Bear in mind that many intel chipsets limit drive speed to UDMA5 (UDMA 100) on all PATA ports.  I note that the ICH7 series of SouthBridges all support SATA 3.0GB/s, except for ICH7-M aka 82801GBM, which supports SATA 1.5GB/s (according to WikiPedia)

Use the manufacturer's tools to do a 'quick' check, then for 'zeroing' (backup data 1st - if applicable) & doing an 'advanced scan' of the drive.  If it's a Seagate drive, use SeaTools DOS TextMode; WD, use DLG for DOS; etc.  This may take a couple of hours.  Do these tests (if you concur) utilizing another board with an uneffected chipset if necessary.

Do not run any manufacturer tests with a USB adapter.

Re: [SLVD] Not able to setup windows

So I got a replacement drive that seems to be OK.  Everything now works at the speed it should, it loads setup files reports the size of the drive Ok lets you make or delete partions... but when I go to format it does nothing and sits at 0%

win xp pro setup C: Partion1 (unknown) 476930MB [476929 MB Free]

on 476938 MB Disk 0 at Id 0 on bus 0 on atapi [MBR]

setup is formatting... 0%

... if I go in BIOS fumbling about trying to make it work in SATA mode it makes NO sense at all.  The manual is useless, as is help in BIOS.  When I change between Disabled, Auto, Combined or Enhanced.  None seem to have helped.   All I seem to get is that it stops me using the PATA dvd drive I want.  I don't know what I'm doing...

Its a gigabyte GA-945GCM-S2L (rev. 1.0) board … mp;dl=1#sp

Last edited by botus (2012-03-23 05:45:57)

Re: [SLVD] Not able to setup windows

Sherlock Holmes used Deductive Reasoning to solve his mysteries.  Similar approaches to electronic hardware yield increasing success rates.

  One place to start may be the CMOS battery.  I use a small WiFi-finder that uses a CR2032 & has a low-battery warning.  It draws a fair bit of current for that style of battery, so weak cells (they can still measure 3 Volts) are easily eliminated.  This is advantageous with even new cells to eliminate 'duds'.  Weak CMOS batteries can yield unpredictable results.  Do not 'flash' anything with such a backup battery unless it is known to pass such a test.  After installing a good battery, short the 'ClearCMOS' jumper for 15 seconds with the P/S unplugged & drained, then remove it.

  Leave the drive disconnected for now.  Ensure that you are using a known-good Power Supply (inspect for blown caps if unsure - power disconnected & drained - ask if unsure - if it's light as a feather, chuck it!).
  Clock everything stock by loading the optimized defaults.  Do this immediately after flashing (if you do so - @ your own risk), too.  Run a 'memtest' on it until it passes (link in my sig.).
  If you have a non-contact IR thermometer (if not, aim to; BIOS rarely tells the whole truth!), 'scan' the board (above & below if possible without blowing yourself up) for hotspots.  Take measurements about 1-4 cm from the target if possible.  When you find them (usually MOSFETs/chipsets/CPU in order of hottest to coolest) make note of any nearby capacitors (within that 'thermal-zone') & their apparent condition.  Mark them for future reference.

  Speaking of BIOS, are you using the latest 'Beta'? … =2669#bios … hBIOS.html  I loathe WinFlashers.  I flash in SafeMode-DOS wherever possible using a small HDD in an enclosure.  Your results may vary.
(remember to load defaults & pass memtest before proceeding)

  OK, now that you've solved any cooling issues (i hate the way stock coolers 'warp' a board over time with no backing plate) & are confidant in the system health, it is time to proceed with the HDD.
  I note that the manual states that <Ctrl><F1> enables advanced options within the BIOS.  Ensure that SMART is enabled.  Stick with Auto for your drives (avoid Non-combined mode - your PATA optical device will disappear as it disables PATA - what a PITA!).

  Consider the possibility that your optical device/disc are a source of error.  (Dirty discs - done dirt cheap!)

  Now power down & get the manufacturer's tools for the drive.  Check the manufacturer's site for any speed-limiting jumper settings (shouldn't be necessary).  Backup any important data if necessary.  Use the manufacturer's tools (<F12> for Boot Menu or change Boot Order in BIOS) to zero the drive & run an advanced test (on another system if necessary).
  If this drive still won't install properly (give the machine an extra fifteen minutes if the drive light remains lit during format), try another SATA drive or use GParted from a linux-live disc for confirmation (time to check warranty remaining on drive?).

  I hope at least some of this helps, and that none of it hurts! smile

Last edited by TechDud (2012-03-25 07:37:26)

Re: [SLVD] Not able to setup windows

Thanks TechDud.  Put drive in another PC and it detected drive (as slave) and windows wanted to format it (which worked ) using some basic diagnostic tools claims all is fine.

Took drive out and put back in this PC but decided to try it in another SATA port... it booted and was happy with same BIOS settings.  And at present windows is installing.  I guess what I should have done was stay with the same port.  But as I'd found nothing I thought I'd try something and now windows is away seemed a shame to stop.

When finished, can I plug it back in the orig SATA port and  (if port OK) will it just boot without worrying which ports its using?

Did spot teh BIOS says it the F8a latest one but with the date a year out !!!

Re: [SLVD] Not able to setup windows

It's not DriverPacks policy to assist with non-DriverPack related issues (time is so precious), but i thought 'what the h*ll'!

One thing i neglected to mention (since i figure that it should 'go without saying'), is electronic cleanliness.  I use an air compressor setup @ about 80psi at a 10cm(4in) distance.  (Safety is critical & your own responsibility - fans can be driven to amputate a digit)  A soft-bristle nylon brush is effective at removing most residue.  It's amazing what glitches this detritus can cause due to stray-capacitance/electric-fields, high-impedance intermittents, and metal plague (including primarily Zinc & Tin).

Why not try to move it to another SATA port?  You do risk the time and effort to obtain success in the first place, though.

They don't always update the 'eye-candy' on a 'beta' BIOS.

Any luck obtaining a non-contact IR thermometer?  Even the 'cheap' models generally yield eye-opening results.  (esp. how biased BIOS can be)

Last edited by TechDud (2012-03-27 10:55:28)

Re: [SLVD] Not able to setup windows

BTW, it only takes about 8 PSI to pierce the skin and even less to pierce the eye.  Compressed air is no joke, be careful.

Read BEFORE you post.  HWID tool   DriverPacks Tutorial   DONATE!
Not all heroes wear capes, some wear Kevlar!

Re: [SLVD] Not able to setup windows

80 PSI is ~5.5 bar!
I'd be careful not to rip a MOSFET, capacitor or some other component off the board...

I use about 3 bar (~44 PSI) to clean out dirt in the car's engine and such - that's mostly sufficient for the task.

Plus, not to forget that compressed air - thanks to the ~21 % of oxygen contained - can built up electrostatic quite easily, which could fry the more sensitive of your components.
Better use compressed nitrogen if you can (no diradical moluecule such as O2, hence no statics build-up).

Anyway, for PC case cleaning, I mostly use a vaccuum cleaner with great results. No damaged components so far wink
It won't get off the dust-nicotine mixture, though, if you're a smoker (bad for your health and that of your PC!)...

Re: [SLVD] Not able to setup windows

Hi Guys thanks for all your help.

The issue was I have only had PATA hardware until I got this board (it probably shows above).  Using what "was" a new release of Mass storage I couldn't get my new build to work using a SATA drive. But the same hardware did everything correctly but using a PATA drive. 

The first time it turns out it was a broken SATA drive not anything to do with mass storage 12.01  I replaced it (with a new SATA drive) and using a new build with mass storage 12.03 I had yet more issues trying to load windows, but with different errors.

mr_smartepants suggested BIOS settings but that it didn't help, but it did suggest he didn't think the mass storage pack was an issue.  TechDud suggested other hardware causes.  I doubted the Board was U/S as it worked on PATA and whilst I did not believe there was any dirt/debris on the SATA cable / port (I do check for this kind of thing), trying some of his ideas seemed to get things moving forward.  1) Proving the new drive was OK, 2) A different port proved BIOS set up was OK 3) At least some of the SATA ports worked, 4) The disc with mass storage 12.03 was OK. 

Both the drives were always listed in the BIOS so I was unaware if it could see them the SATA connection could ? be dodgey.

Today I put the same cable back on where first I started, with the BIOS settings where I had started, used all the same hardware I started with (bar the second SATA drive) and with the windows disc build I started with (12.03) and its booted up into windows I loaded last night as though there had never been any issues.

Last edited by botus (2012-03-28 04:06:02)

Re: [SLVD] Not able to setup windows

I've seen SATA cables that looked otherwise fine go bad.  I just ordered a stack of new SATA cables from for about $0.60 each.  I always try to keep a stash of spare cables, just in case.

Read BEFORE you post.  HWID tool   DriverPacks Tutorial   DONATE!
Not all heroes wear capes, some wear Kevlar!

Re: [SLVD] Not able to setup windows

This board has continued to work fine (so long as you format on another computer) but would not allow any drive to be formatted during windows install in the configuration I had, the BIOS setup had no impact.

Neither a DP'd win disc or Std win disc made any difference.  The PC loads either disc allows you to get to the format part of the install then it sits and achieves nothing

Last time round I searched the net for a reason and came across a support doc (I can't find anymore) stating quite a few Gigabyte boards behave this way when you are using a SATA harddisk and an IDE DVD drive

Finally got round to putting a SATA DVD drive in and the problem disappears.  It now installs windows (and formatting without issue).

I guess its new to people here or a long forgotten peculiarity with this set up that should be more widely understood?

Last edited by botus (2012-10-26 05:47:27)