Topic: "WinSat.exe system error" Msvcr100.dll cannot be found!

Hi,
This is my first message. When "Windows Vista/7 x86 Graphics Mobile 12.03" driver pack is integrated by using WinKit program by @Legolash2go at Wincert.net, system performance test gives the below error message while driver is install a system with ATI Radeon mobility HD 5650 VGA:

"WinSat.exe system error. Msvcr100.dll cannot be found"


After so many attempts, I resolved the problem by this process:
I deleted all ATI folders in 12.03. Then, I pasted ATI folders from 11.11 to 12.03. I got no error messages.

I wanted to inform you about this problem. ATI drivers in 12.03 seems to be problematic.
Thank you.

Last edited by erkan (2012-05-23 02:06:44)

Re: "WinSat.exe system error" Msvcr100.dll cannot be found!

Well, I don't know what to tell you but that file isn't in any of the DriverPacks. 
It's not missing, it was never there to begin with.

It's part of Microsoft Visual C++ Redistributable package.

Re: "WinSat.exe system error" Msvcr100.dll cannot be found!

mr_smartepants wrote:

Well, I don't know what to tell you but that file isn't in any of the DriverPacks. 
It's not missing, it was never there to begin with.

It's part of Microsoft Visual C++ Redistributable package.

I realized that it is part of Visual C++. However, whether Visual C++ is install or not, I have the same error. The only solution is to change the ATI folder.

Strange but real!

Last edited by erkan (2012-05-23 02:01:19)

Re: "WinSat.exe system error" Msvcr100.dll cannot be found!

I can confirm this is a issue on ATI's side, I have been usin ATI's drivers to make my own DP's and then all of a sudden I got this same error on a install of win 7 x64 Pro, I thought the drivers were corrupted.

I re download the x64 drivers from ATI and made my DP up, integrated them, and did a clean install, and the error was present, the same happens to x86 users also.

The MSVCR100.dll is in the main folder after extracting the ATI_xxx_ccc_ocl.exe, witch I thought was/is very stupid of them to do, knowin many, many people integrate these drivers and it would cause issues.

I have checked the drivers from 11.9's on up, this MSVCR100.dll is in 11.11's on up, nothing can be done about it, use the 11.10's for integratin, then install 11.11's full package onward is wat I am doin.

There is not much info about this in google search either.

EDIT:
In fact, if anyone would like to affirm this, just download any newer version of the ATI drivers from ATI ( version 11.11 on up ), act like yer goin to install the .exe, then cancel install, then go to the extracted folder witch in my case is C:\ATI, in this folder do a search for MSVCR100.dll, you will find., get any version earlier than 11.11, do the same, no MSVCR100.dll.

Last edited by emplosion69 (2012-05-15 12:10:14)

Re: "WinSat.exe system error" Msvcr100.dll cannot be found!

it would seem it would be easier just to seed msvcr100 rather than doing two installs...

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: "WinSat.exe system error" Msvcr100.dll cannot be found!

Correction, msvcr100.dll starts in the 11.12's, not 11.11's, I just downloaded them all again to recheck ( for desktop PC )

if the msvcr100.dll could be added to the DP's than that would fix these newer drivers for all, full install of ATI drivers, it is placed into the 'C:\windows\system32' folder

If there is a test version of this done, I will test the DP out smile I use win 7 x64 Pro and desktop PC not mobile ( just noticed this was a Mobile section )