Topic: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

I am using DPINST to install the NT5 Graphics 1005 driver pack on a Dell Optiplex 745. Even using all three (A, B, C) graphics packs the ATI Radeon 256MB X1300 Pro driver was not found. I have downloaded the driver from the Dell site and then installed it. I then extracted the driver and built a 7z file based on the driver. Where do I send the driver so that it gets added to the next release?

Regards
Peter Nesic

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

Please just post the download link for the driver along with the HWIDs of the video hardware in your Dell.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

Can you supply me with a location to place the files?

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

you can't post them for us... Since we won't accept drivers from third parties....
We need you to post the direct link to where you downloaded it from at Dell...

thanks for your feedback!

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

I have attached the driver here:

http://www.sendspace.com/file/na1pv9

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

We still don't accept drivers from third parties like rapid share or other...

you will have to post a link to the original download at Dell or it will not be added. You must also include the HWID of the device.

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

SOETool wrote:

I am using DPINST to install the NT5 Graphics 1005 driver pack on a Dell Optiplex 745.

Your statement confuses me.  Are you saying you use a SAD disc, or you try to use dpinst.exe on it's own to install drivers?

No need to upload drivers anywhere, your HWID is already supported in the current release of DriverPack Graphics C.
If it's not being detected, then you are doing something wrong.
Please tell us exactly what you are doing to install the drivers? on what OS?  Log files too please?

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

All I did was download the latest driver packs from the download page in 7zip format. I extracted them and then ran DPINST accross it with seaching sub folders and in legacy mode to install unsigned drivers. All drivers install accross the eight different computer types we have except for this one video card.

I don't want to toot my own horn, but I write drivers for a living and I know a few things about them. Anyway the INF file I attached contains the following section.

"128MB ATI Radeon X1300" = ati2mtag_RV515, PCI\VEN_1002&DEV_7187&SUBSYS_04021028
"128MB ATI Radeon X1300 Secondary" = ati2mtag_RV515, PCI\VEN_1002&DEV_71A7&SUBSYS_04031028
"256MB ATI Radeon X1300PRO" = ati2mtag_RV515, PCI\VEN_1002&DEV_7183&SUBSYS_0D021028
"256MB ATI Radeon X1300PRO Secondary" = ati2mtag_RV515, PCI\VEN_1002&DEV_71A3&SUBSYS_0D031028

I downloaded and extracted the the following files DP_Graphics_A_wnt5_x86-32_1005.7z, DP_Graphics_B_wnt5_x86-32_1005.7z and DP_Graphics_C_wnt5_x86-32_1005.7z. I then performed a grep looking for VEN_1002&DEV_71A3&SUBSYS_0D031028 and I did not find this in any file.

The actual Hardware ID I am looking for is PCI\VEN_1002&DEV_7183&SUBSYS_0D021028 which is the third one in My INF file obtained from Dell.

I then looked at two files with the dirver packs: \D\G\A\CX_76825.INF and \D\G\A\CX_95952.INF. Both INF files had entries for VEN_1002&DEV_7183 and SUBSYS_0D021028 but not VEN_1002&DEV_7183&SUBSYS_0D021028.

On line 945 of CX_76825.INF and on line 430 of CX_95952.INF it lists VEN_1002&DEV_7183 and its remarked. If it wasn't remarked it would work and install the driver correctly as all the files seem to be there.

Its seems to be just a matter of adding the correct line to the INF or removing the remark.

Regards
Peter Nesic

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

SOETool wrote:

line 430 of CX_95952.INF it lists VEN_1002&DEV_7183 and its remarked. If it wasn't remarked it would work and install the driver correctly as all the files seem to be there.

I'm looking at it right now and that HWID is NOT "remarked", commented, or hidden in any way in CX_95952.inf.  CX_95952.inf in DriverPack Graphics C 1005 is signed by ATI and unaltered by us.  If it's remarked, then someone else did that.  CX_76825.inf is heavily altered by me and is from a different driver entirely.  That HWID is supposed to be blocked in CX_76825.inf.
I suggest you redownload DriverPack Graphics C 1005 and check for yourself.
It's refreshing to have a support "call" from someone who knows the material!  Instead of the usual "Hey dude your stuff is broke, fix it" posts. wink
So you'll understand how dpinst will do a recursive search for a HWID through each .inf and "rank" any possible matches.  An ideal match would be a total VEN_*&DEV_*&SUBSYS_*&REV_* match with a signed driver (if available).  Those are rare, so the next ideal match would be VEN_*&DEV_*&SUBSYS_* and then VEN_*&DEV_* (we term that "generic") with the last choice being VEN_* (a "Super-generic").
I haven't had the best of luck using SAD (which calls dpinst) on ATI hardware.  Their drivers just do not react very well to that environment.  The recommended install method is direct integration into the OS source.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

Hi,

Its been a while since my last post, but I have finally solved this problem. It seemed that even if the drivers where part of the driver packs they where not installing. The problem seemed to occur on many different computers including laptops, so after spending many many weeks looking in to the issue, I looked at DPINST.exe.

It seems that Microsoft has two switches that allow you to automate DPINST to not show its screen to the user. You can either use <quietMode/> or <suppressWizard/>. Now both do exactly the same thing, except if you use <quietMode/> with <legacyMode/> it will not install some drivers, even signed drivers. However if you use <suppressWizard/> with <legacyMode/> it workes all the time as you would expect. There is no information on the Microsoft site about this issue.

http://msdn.microsoft.com/en-us/library/ff553383.aspx

After knowing the answer and searching on the interent I realised others have the same issue, so here is the solution.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

You're describing the .xml entries.  We don't use <quietmode/> or <suppresswizard/> at all.  We only use the below as a default.

<?xml version="1.0" ?>
  <dpinst>
    <search>
      <subDirectory>*</subDirectory>
    </search>
   <scanHardware/>
   <legacyMode/>
   <enableNotListedLanguages/>
   <suppressAddRemovePrograms/>
  </dpinst>

And the command to execute dpinst.exe we use is:

Start "MicroSoft Driver Pack Installer Tool Running" /wait /separate /realtime /min CMD /C DPInst.exe /c /s

again, no quiet mode, only silent mode.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

From the MS documentation

"/q or /s
Sets the quietInstall flag to ON, which suppresses the display of wizard pages, user dialog boxes, and other user messages that DPInst and Windows generate. The quietInstall flag works with the presence of an end-user license agreement (EULA) page and the suppressEulaPage flag."

so our DPInst.exe /c /s is the equivelent of useing the xml entry <quietMode/>

Perhaps we should try

<?xml version="1.0" ?>
  <dpinst>
    <search>
      <subDirectory>*</subDirectory>
    </search>
   <scanHardware/>
   <suppressWizard/>
   <legacyMode/>
   <enableNotListedLanguages/>
   <suppressAddRemovePrograms/>
  </dpinst>
Start "MicroSoft Driver Pack Installer Tool Running" /wait /separate /realtime /min CMD /C DPInst.exe /c

and see if that is better

Thanks for your feedback SEOTool, it helps make DriverPacks better for everyone!!!!

Jeff

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: Found NT5 X1300 Pro Video Driver on a Dell Optiplex 745

I'm moving this to Feedback and support BASE... requests... big_smile

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.