Topic: Strange things happening. Driver issues also.

I've downloaded the special plugin for UBCD4WIN.  Installed all the driverpacks I wanted.  LAN, Chipset, and Mass_Storage.  I then also created a pack myself and placed it under the 3rd party yesterday enabled and configured and built my CD and every driver was placed onto the project and everything seemed fine.  I disabled or removed all drivers from the normal Net and SCSIAdapter folders before hand.  All Lan, my 3rd party and of course the mass storage all where there and worked the way it should.   

Today I tried creating again but this time no matter what I do, the additional files I created would not get added to the project.  Even if I configured again, disabled/enabled and tried again no matter what, they would not add my 3rd party drivers.

Now onto a driver issue that seems to have been here and I can not get it working.  We have HP DL380 G5 machines at work and they have HP373i Multifunction onboard on them which also can equate to Broadcom NetXtreme II GigE cards.  The only problem is no matter whom has created packs or even when you add these drivers yourself they will not work and always get picked up as ordinary Broadcom NetXtreme cards not II.  Of course if you even add the HP373i drivers the cards are still found as ordinary Broadcom NetXtreme. 

Littlbugger's drivers would also not work and now that I've come back to using the DriverPacks which I used to use in the past these NetXtreme II cards are never identified properly either as the proper HP373i's or Broadcom II.

I was able to finally get my files I mentioned above incorporated again, but I had to manually put them into the Net and SCSIAdapter folders as you would in the past for BartPE but why would they work one day but not the next doing it the proper way of building 3rd party packs??? 

I will test at work tomorrow and report if this new build will work or not. 

Seems no matter whom creates driver packs for the NetXtreme II or HP373i they never seem to work and always seem to overwrite each other or simply just do not work.  Maybe after testing tomorrow this will change?  The strangest thing though if you use a DOS boot disk it finds the HP373i as a Broadcom NetXtreme II and works perfectly fine but when trying to get these incorporated into say RIS, PE etc. just do not function.  Please help if you can and thanks in advance.

Last edited by Cellar Dweller (2007-04-13 12:26:16)

Re: Strange things happening. Driver issues also.

I don't understand: what's your goal?
Do you create a BartPE or windows installation?

Which special plugin for UBCD4WIN did you downloaded?
Dosn't this support massstorage drivers only?

We have HP DL380 G5 machines at work and they have HP373i Multifunction onboard on them which also can equate to Broadcom NetXtreme II GigE cards.

A HP373i Multifunction seems to behave strange. … Id=1086304

Which driver did you added? … 26803.html
This driver supports the following HP NC-Series Multifunction NICs: NC373i

%NC373i_desc% = NC373i_x86w2k, b06bdrv\l2nd&pci_164c14e4&subsys_7038103c

"b06bdrv\l2nd&pci_164c14e4&subsys_7038103c" is a strange HardwareID.

Which HardwareID does your device list?

A "Broadcom BCM5706C NetXtreme II GigE" refers to:
%bcm5706c_desc% = bcm5706c_x86ws3, PCI\VEN_14e4&DEV_164a

Re: Strange things happening. Driver issues also.

My goal is to get these onboads to work with UBCD4WIN or BartPE to pull images to the servers. 

I create a boot disk as normal and we then use the network to pull an image down to the systems, but no matter what driver I've tried in UBCD4WIN comes back with network adapter can not be installed but yet it shows them in Device Manager as the Broadcom NetXtreme II GigE adapters and are yellow exclamationed.  When trying to manually change to the HP373i they just don't work, they won't install. 

Yes the special plugin supposedly only works with the Mass Storage but what is weird is how or why is it working with all the other items?  When you look in the log file it shows that it finds the Lan, Chipset, and 3rd Party that I've put there.  The strangest thing was it loaded all of them up and everything was there and on my project.

Unless it's simply pulling all the drivers from Windows\source and I'm getting confused on that?  This could be the case because I've emptied out the Net and SCSIAdapter folders but it pulled in my 3rd party pack I made at least the first day I tried it but then didn't the next day when adding others trying to resolve my issue with these drivers. 

I thought your driver packs have always worked with BartPE? I remember setting up the plugins years ago and since UBCD4WIN is just another version of BartPE with additional plugins it should just work straight out of the box or is it not working that way? 

These are all the items I've tried to get these working period.  I've used the latest broadcom netxtreme II drivers, I've used the latest HP 373i drivers, I've even used the RIS only broadcom driver b06nd.inf / b06nd50x.sys.  I've done them all seperately and I've tried with them all included.  Something keeps them from working.

The Dos boot disks keep finding these cards as the Broadcom NetXtreme II GigE and it works fine, but we don't want to use a boot floppy and want a single CD to use so that we have all the other tools for troubleshooting.   We also need the regular broadcom drivers and all other drivers due to the different systems we have from IBM, Dell, HP... 

I used Littlebugers drivers, I've used the old BartPE way of putting them in manually and now tried to use the Driverpack way.  Either way I've tried nothing seems to work.   

This is what shows up once Windows 2003 Server is installed for what the onboards are: HPNC7782 - q57xp32.sys


This driver is on or included with your driverpacks and with LittleBugers and is on the project but somehow gets crossed off or conflicts with others included somehow because the HP and Broadcoms come back as all the same or something... 

Any help would be greatly appreciated and thanks for the quick reply...  I can't believe I'm the only one with this kind of issue with how many companies use HP servers and DL380 G5's...

Last edited by Cellar Dweller (2007-04-16 21:57:30)

Re: Strange things happening. Driver issues also.

Cellar Dweller wrote:

My goal is to get these onboads to work with UBCD4WIN or BartPE to pull images to the servers.

Currently Massstorage drivers are tested and supported.
Adding additinal drivers may work or not.

There had been NOT a official DriverPacks BartPE solution in the past.
There had been third party DriverPacks driver plugins.

Broadcom offers a RIS driver: … 2-2003-RIS … p;p=122288

mcclusky5 wrote:

open the b06nd.inf and change the class=net to class=Net

%bcm5706c_desc% = bcm5706c_x86ws3, PCI\VEN_14e4&DEV_164a
%bcm5706s_desc% = bcm5706s_x86ws3, PCI\VEN_14e4&DEV_16aa
%bcm5708c_desc% = bcm5708c_x86ws3, PCI\VEN_14e4&DEV_164c
%bcm5708s_desc% = bcm5708s_x86ws3, PCI\VEN_14e4&DEV_16ac

However PCI\VEN_14E4&DEVICE_1648 is not listed.

HP uses a OEM hardware from Broadcom.
You may have to use a HP driver. A IBM driver may work or fail too.

TheBronze got woring network at a DL360G5. IBM drivers was used. … p;p=125591

Majava reports working IBM package with HP NC373i (ProLiant DL360G5 and DL380G5) … p;p=125357 

Try Broadcom RIS driver, edit b06nd.inf class=Net and insert PCI\VEN_14E4&DEVICE_1648.
Find a RIS driver containing PCI\VEN_14E4&DEVICE_1648, edit b06nd.inf class=Net.

Cellar Dweller wrote:

I can't believe I'm the only one with this kind of issue with how many companies use HP servers and DL380 G5's...

Or they haven't wrote there solution.
Ask HP.

Or donate a HP DL380 G5 Server to a DriverPacks developer.

Re: Strange things happening. Driver issues also.

cdob is correct BartPE has never been supported before

and he is also correct that the plugin created only has drivers for mass storage text mode.

any other driverpaks including regular mass storage drivers (the non text mode support drivers) will be ignored when creating a plugin.

this will change once the mass storage text mode drivers prove to be stable and no bugs show up.

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: Strange things happening. Driver issues also.

Cellar Dweller wrote:

This is what shows up once Windows 2003 Server is installed for what the onboards are: HPNC7782 - q57xp32.sys

PCI\VEN_14E4&DEVICE_1648&SUBSYS_00D00E11&Rev_10\5&8A2758C&0&090008 b57win32.inf refers a VEN_14e4&DEV_1648 to a "Broadcom NetXtreme Gigabit Ethernet".

%BCM5704%           =  BCM5704.Inst,           PCI\VEN_14e4&DEV_1648
BCM5704             = "Broadcom NetXtreme Gigabit Ethernet"

This is not a NetXtreme II.

If a HP 373i use a HardwareID DEV_1648 and use NetXtreme II compatible chip, this may lead to major confusion.

However HP offers cp007293.exe for a NC7782.
And HP offers cp007290.exe for a NC373i.

cp007293.exe q57win32.inf
%NC7782%    =  NC7782.XpInst,    PCI\VEN_14e4&DEV_1648&SUBSYS_00d00e11
NC7782              = "HP NC7782 Gigabit Server Adapter"
There is a HP OEM q57xp32.sys v10.24.0.0 included, not a broadcom version.
This HP OEM *.sys may be necessary or not.

Broadcom offers NetXtreme Drivers 10.24d.
A general Broadcom driver q57xp32.sys v10.24.0.0 may work at OEM hardware or not.

I'm using general Broadcom driver at a HP PCI\VEN_14E4&DEV_167B&SUBSYS_280C103C.

If your HardwareID is PCI\VEN_14e4&DEV_1648&SUBSYS_00d00e11 (&DEV_ not &DEVICE_),
remove all HP and Broadcom drivers and try HP cp007293.exe drivers.

Does a DL380 G5 use different nic hardware?

Re: Strange things happening. Driver issues also.

Well we do so many of these servers it's so hard trying to remember or figure out exactly which driver or onboard isn't working.  I do know that it equates to the NetXtreme II card at least that's what the floppy boots always see them as and they work fine that way.

For whatever reason no matter what version of driver used from Broadcom, HP for the NetXtreme II's or 373i they just don't work. 

I just checked another server and this is if I'm correct is truly the one causing the issue and is the 373i.  Sorry about the confusing item posted previously, that was a different onboard.  Seems these combo HP/Broadcoms are just nothing  but issues with PE. 


I've yet to be able to test what I've done which is that class=net to class=Net thing which I did find while searching the internet over the last week.  This may fix the issues overall.  I'll post back with my findings on doing what was on 911cd.  Thanks to everyone for your information but I've seen all of that and keep testing each item.  As I said the editing of the inf is where I stand right now and it may work as they posted on the other site only time will tell.  I'll keep you posted, problem at this moment is waiting for more servers to come in to test the boot CD on.  Once this happens I'll see if my newly created disk will work with the editing of the inf. 

Thanks again.

Last edited by Cellar Dweller (2007-04-18 07:24:27)

Re: Strange things happening. Driver issues also.

Ok everyone the downloading of the RIS drivers for the Broadcom NetXtreme II and editing of the inf file and changing class=net to class=Net allowed the project to finally add the driver.  I was then able to test today on the system in question and it finally saw the HPC373i as a Broadcom NetXtreme II which was my goal.  Now at this point everything seems to be functioning fine.  Thank you all for your posts and the quick responses. 

This could be something added to the driver packs to allow everything to function properly and keep the HP and Broadcoms from overwriting or conflicting with one another. 

I'll be waiting anxiously for you and UBCD4WIN to get all the packs as a standard for their project and thanks for all the hard work both your teams have done thus far on getting the mass storage devices finally included now to move onto the network and then we all can be happy... Thanks again. 

On another note the P400 and P400i drivers for Mass Storage (Are they included on your driver packs?) - I know that the Windows 2003 versions do not work it will blow up every time looking for a sys file, but I have been able to work around this by adding a Windows 2000 version of the driver that works with UBCD4WIN and BartPE...