Topic: cd/dvd device driver missing on install

ok, i've seen this problem all over the net, and it seems the problem is really a missing/non-working raid or sata controller. i also found what seems a viable solution. i put the x64 9.10 (where's the 9.12?) driverpack on a thumb drive, browse to the folders, hid all incompatible drivers, and selected all of them, clicked next, and it installed most of them. a couple failed, most worked. but when it finished, nothing was different, the same screen was there and the only thing i could do was cancel windows install, or click next, which just installed all of the drivers again.

can somebody help me out with how to slipstream properly (i'm using windows xp 32bit if that makes a difference), or what i'm doing wrong to install those drivers during the install?

Re: cd/dvd device driver missing on install

ok after already having looked all around the site for things to help, i finally had the stroke of genius (read: i'm a moron) to get the mass storage driverpack maybe 5 minutes after the first post, since it looks like those are the drivers for sata/raid and whatever. i'll let you know how things turn out smile

ps if anybody has helpful info anyway, please enlighten me - i can work with pc's but i'm still a noobie

Last edited by contare (2009-12-18 16:52:26)

Re: cd/dvd device driver missing on install

no such luck, i think the drivers for my board aren't included in the mass storage driverpack. so, back to the original question. and i forgot to mention, i have the intel g31/g33 express chipset.

thanks in advance smile

Re: cd/dvd device driver missing on install

Welcome to DriverPacks!
Well, your details are scarce.
What OS are you trying to integrate DriverPacks into?  ie, what are you trying to install that is failing?
Post the HWIDs of the hardware in question. (tool linked in my signature)

If you're trying to integrate DriverPacks into a Win7 source, use the dism-tool (linked below this section).

Any more info you can provide?  Click the "read before you post" link in my signature.

Re: cd/dvd device driver missing on install

Yeah I did look around, but i seem to have done a crappy job of it... No more 2am computer work for me tongue

anyway sorry about that. I'm at work so I can't get the hwid's just now, but I'm trying to get windows 7 ultimate x64 running. I don't know my exact motherboard, but I do know it's the g33/g31 express chipset. I'm not dead set on slipstreaming, as I believe I'd be ok with the right sata/raid controllers. I haven't been able to find them from anywhere as of yet- intel's website sucks for that.

If this helps any, awesome, if not I'll have the hwid's stuff up soon as I get home.

Re: cd/dvd device driver missing on install

ok, back home finally. sorry for not being the quickest on the draw here :\

still crackin on the problem myself, and here are all of the HWIDs in the raid section from the hwid tool

============ 
RAID Devices 
============ 
PCI\VEN_1283&DEV_8211&SUBSYS_82111283&REV_11\4&2C3BA146&0&10F0
    Name: ITE IT8212 ATA RAID Controller
    Hardware ID's:
        PCI\VEN_1283&DEV_8211&SUBSYS_82111283&REV_11
        PCI\VEN_1283&DEV_8211&SUBSYS_82111283
        PCI\VEN_1283&DEV_8211&CC_018000
        PCI\VEN_1283&DEV_8211&CC_0180
    Compatible ID's:
        PCI\VEN_1283&DEV_8211&REV_11
        PCI\VEN_1283&DEV_8211
        PCI\VEN_1283&CC_018000
        PCI\VEN_1283&CC_0180
        PCI\VEN_1283
        PCI\CC_018000
        PCI\CC_0180
PCI\VEN_8086&DEV_2920&SUBSYS_5044107B&REV_02\3&61AAA01&0&FA
    Name: Intel(R) ICH9R/DO/DH 4 port Serial ATA Storage Controller 1 - 2920
    Hardware ID's:
        PCI\VEN_8086&DEV_2920&SUBSYS_5044107B&REV_02
        PCI\VEN_8086&DEV_2920&SUBSYS_5044107B
        PCI\VEN_8086&DEV_2920&CC_01018F
        PCI\VEN_8086&DEV_2920&CC_0101
    Compatible ID's:
        PCI\VEN_8086&DEV_2920&REV_02
        PCI\VEN_8086&DEV_2920
        PCI\VEN_8086&CC_01018F
        PCI\VEN_8086&CC_0101
        PCI\VEN_8086
        PCI\CC_01018F
        PCI\CC_0101
PCI\VEN_8086&DEV_2926&SUBSYS_5044107B&REV_02\3&61AAA01&0&FD
    Name: Intel(R) ICH9 Family 2 port Serial ATA Storage Controller 2 - 2926
    Hardware ID's:
        PCI\VEN_8086&DEV_2926&SUBSYS_5044107B&REV_02
        PCI\VEN_8086&DEV_2926&SUBSYS_5044107B
        PCI\VEN_8086&DEV_2926&CC_010185
        PCI\VEN_8086&DEV_2926&CC_0101
    Compatible ID's:
        PCI\VEN_8086&DEV_2926&REV_02
        PCI\VEN_8086&DEV_2926
        PCI\VEN_8086&CC_010185
        PCI\VEN_8086&CC_0101
        PCI\VEN_8086
        PCI\CC_010185
        PCI\CC_0101
3 matching device(s) found.

Re: cd/dvd device driver missing on install

just tried to run the dism tool, it crashed immediately on running. "Dism Mount tool has encountered a problem and needs to close."

*edit* just realized i never really did say that wasn't working. i'm trying to install windows 7 x64, and as soon as the installer finally gets up and running, it pops up an error saying 'a required cd/dvd driver is missing.' i then get options to load drivers from a floppy, cd, or usb.  i can't seem to find the right drivers for it, even though i grabbed the entire chipset driverpack and the entire mass storage driverpack.

Last edited by contare (2009-12-19 15:44:38)

Re: cd/dvd device driver missing on install

Please read the tutorial on DISM by Muiz - http://forum.driverpacks.net/viewtopic.php?id=3716

This explains how to add drivers manually to a Win7 image.
Please note it is neccessary to Mount the WIM and update it to get the neccessary support added to your WIM to enable it to find your HDD.

Muiz has also privided a link to a tool to help simplify the process  here - http://forum.driverpacks.net/viewtopic.php?id=4200

(did you extract the drivers from the pack?)

ITE and ICH9 are very common intel drivers, and are included in the packs.
I suspect the driver you need is not a standard Mass storage driver, Perhaps it is a Card Reader? (which would not be included in mass storage or chipset) Since you did not include the full report of your HWIDs we can still only guess...

Did you install from a DVD? Did the installation find your HDD?
Are you trying to install on the same system you are preparing the image on?
or are you useing one to create the image and a second one to install to.
What is the OS you are useing to manipulate your win 7 image.
Is the target a white box or a production machine (IE homemade vs a Dell or HP)

If you want help you are going to have to spill the beans.
We are not psychic and we are not going to play 20 questions with you.

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: cd/dvd device driver missing on install

ok color me stupid sad

i checked out that guide. i mounted my win7 iso, but i cannot find a system32 folder anywhere on it. also, my current OS is xpPro 32bit, so i can't use the winIntegrator. also, the DISM tool is crashing immediately.

as for the card reader thing, i dont have anything like that. my box is fairly simple as far as things attached - gpu, optical drive, sata hard drive. thats pretty much all i have in my pc. i know the ite and ich9 stuff is pretty common, but when i hook up my usb drive while the w7 installer is up, i check the 'hide incompatible drivers option' and everything disappears. there are plenty in the chipset driverpack that still show up, but they dont seem to solve the problem. i opened up iaAHCI.inf in the massStorage pack, in folder 7-1 (intel folder), and it looks like this line:

PCI\VEN_8086&DEV_2922&CC_0106.DeviceDesc    = "Intel(R) ICH9R/DO/DH SATA AHCI Controller"

is one digit off of what the HWID tool shows for the corresponding line in the RAID devices section:

PCI\VEN_8086&DEV_2920&SUBSYS_5044107B&REV_02\3&61AAA01&0&FA

i'm not sure if i'm even looking at the right things, but it seems as though it's slightly off of what i have?

Re: cd/dvd device driver missing on install

DON'T HIDE ANY DRIVERS!!!

The Working Driver just might be in the "incompatable" list!


IE Win7 may mark a Vista driver as incompatable, BUT all Vista drivers ARE fully Win7 compatable!
Much as many XP drivers come up with a warning that they are not "Digitaly Signed" but that does not mean they won't work or even that they are not the proper driver... smile.

Did you copy the DISM tool to your HDD from windows 7? or are you trying to run it from the DVD?
(you have to have win 7 already installed on a machine to be able to get it the way he describes)
if you do not have win7 installed you must download the WAIK for win7 from MS. (He says this in his instructions)
link to WAIK download http://www.microsoft.com/downloads/deta … laylang=en

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: cd/dvd device driver missing on install

hm, now that you mention that old digitally signed bs, i wonder why i didnt think to just not hide stuff to start with, lol. i'll try that in a few minutes here (cooking chicken for late dinner yay!). thanks for the noob check, i'll let you know in about 20 minutes if it didnt work, or hopefully in an hour or so (however long install takes tongue) if it does work

Re: cd/dvd device driver missing on install

still no dice, and i somehow managed to miss needing the WAIK thing. will that help if i'm having trouble even finding the right drivers? (i'm trying it anyway in the interim while waiting for an answer smile )

Re: cd/dvd device driver missing on install

yeah i did not find your HWID in the X64 or x32 Mass pack (PCI\VEN_8086&DEV_2920)

I am trying to determine if that is natively supported in win 7 now...

Um nope it won't help providing the drivers... It will however help with adding them to your install media wink.

The only reason i can think of that Muiz did not already add them is because they are not needed wink.
IE they are included already. Trying to verify that now big_smile

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: cd/dvd device driver missing on install

ok i'm working on going through the step-by-step stuff for the w7 AIK now (fell asleep last night neutral ) i'll let you know how things turn out smile

Re: cd/dvd device driver missing on install

hrm reading the instructions on this, and i don't have a spare computer to work with this on, and i don't have vista on any machine anyway, so according to the requirements i can't run the WAIK anyway. is this something that can still be done on a single pc? i just dont want to wipe out this windows until i know i can get up and running on something else tongue  one way or another, i'm still digging around with this tool to see if i can't get something working anyway.

also, overflow, if it were supported natively on the win7 disc, this problem wouldn't have come around, would it? or am i missing something stupid here :>

come to think of it i do have a windows 7 32bit at my disposal as well, i might just try to get that running, then start using the tools listed here. i'll get back to you on that smile

Last edited by contare (2009-12-20 04:07:58)

Re: cd/dvd device driver missing on install

also, something that i've tried but having serious troubles with - how would i go about at least attempting to get the drivers from one of the intel packages? i've tried downloading their matrix manager thingy, which i believe has all the drivers and such in it, but it wont run (i guess because it's for the 64bit systems), and when i try to extract it there are no driver-looking files in there.  if anybody smarter than me knows how or can figure out how to get drivers from one of their packages and detail that, it might solve the problem here.

Re: cd/dvd device driver missing on install

ok another update: i finally thought to switch the emulation mode off of ide and onto ahci before booting from the w7 disc. stuff actually started showing up even when i had the hide incompatible option checked. i still went into the incompatible section and tried loading other stuff, but it still doesn't seem to be helping anything. i did notice however that at least one (maybe 2 or 3?) of the drivers shown as compatible now had the 2922 number like

PCI\VEN_8086&DEV_2922&CC_0106.DeviceDesc    = "Intel(R) ICH9R/DO/DH SATA AHCI Controller"

the first code section i posted several posts above here.

ps - i apologize for having a lot of posts to have my say. its a bad habit of mine hmm

Re: cd/dvd device driver missing on install

Maybe i can help?
But then i need to know what motherboard you are using.
And are you trying to do all this from XP?
And the driver for : "Intel(R) ICH9R/DO/DH SATA AHCI Controller" is present in the packs.

So i need a bit more info from you....

Re: cd/dvd device driver missing on install

I can't remember the exact board I have, and I'm at work so I can't check just now- all I know for certain is that it's an intel and starts with DG... Not much help for that.

Yeah, I *was* running xp, but I went ahead and installed 32bit in the hopes I can make the 64bit version work from there, so tonight I'll work with dism and see I that'll take care of it. I'll also snoop out my exact motherboard for you when I get home. Thanks guys smile

Re: cd/dvd device driver missing on install

Glad to see you Muiz!

His HWID is PCI\VEN_8086&DEV_2920
and although the ICH9 driver IS present in the pack THAT HWID is not included... wink

Yes was is trying to do all this from XP. now he has win7 x32

@contare
Hmm. Yes your right, if it was included natively we would not have this issue... Duh! blonde moment wink.
Do you even have a 64bit processor? (since you did not include your full HWIDs list we don't know...)
DISM will install and run from XP. I am doing this right now. wink

DP BartPE Tutorial   DP_BASE Tutorial   HWID's Tool     Read BEFORE you post    UserBars!
http://driverpacks.net/userbar/admin-1.png
The DriverPacks, the DP_Base program, and Support Forum are FREE!.

Re: cd/dvd device driver missing on install

Yeah I checked on that a good while ago... I'm definitely x64 capable. And as for the hwid not being listed, I think I may have solved that problem... When I switched my data emulation from IDE to ahci, it seemed like the last 4 digits (2920) changed to 2922 which is listed. I still couldn't get up and running though, and current install won't boot with that change, so I can't verify that for certain unless somebody can tell me how to boot that way.
Sorry for such a slow response, the jefe has been hanging around for the last few hours

Re: cd/dvd device driver missing on install

so i'm being lazy and not looking up my exact board just yet (i really don't feel like crawling under my desk just yet), so i'm going ahead and seeing what i can manage with dism and/or the winIntegrator tools.

to be continued... tongue

Re: cd/dvd device driver missing on install

so, i'm now wishing i'd just gotten on my x86 w7 sooner... that winIntegrator is pretty slick...easy and all haha. about to try to load off of that disc, be back sooner or later (hopefully later?)

Re: cd/dvd device driver missing on install

officially completely stumped... i used the win integrator, added all the .inf's out of the intel folders from both the chipset and the mass storage driverpackages, i selected both the iaStor and the iaAHCI ones from the mass storage folders as boot critical, hit the apply button, created iso, burn, boot... still having the same problem.  idiot check... did i do something wrong, or skip a step?

on a side note, i've already been contemplating getting a new motherboard anyway, and between having these issues, not to mention being between installs being a good time to do that anyway, would that likely get rid of this problem anyway?


@muiz:
as of right now, i am running windows 7 ultimate x86, and am trying to install windows 7 ultimate x64. i have the intel motherboard DG33SXG2.  in my bios, the option "configure sata as:" is currently set to IDE, and i have tried to get the boot installer running with it set both as IDE and as AHCI. i thought maybe running as AHCI might resolve the problem, but so far hasn't, and my current install won't boot with it set as AHCI so i can't get you a HWID log that way (would that even change things?).  also, here's a full HWID log, ran it about 45 seconds ago.

=========== 
PCI Devices 
=========== 
PCI\VEN_8086&DEV_293A&SUBSYS_5044107B&REV_02\3&18D45AA6&0&EF: Intel(R) ICH9 Family USB2 Enhanced Host Controller - 293A
PCI\VEN_8086&DEV_29C0&SUBSYS_5044107B&REV_02\3&18D45AA6&0&00: Intel(R) G33/G31/P35/P31 Express Chipset Processor to I/O Controller - 29C0
PCI\VEN_10DE&DEV_0612&SUBSYS_087D19F1&REV_A2\4&C971561&0&0008: NVIDIA GeForce 9800 GTX/9800 GTX+
PCI\VEN_8086&DEV_2930&SUBSYS_5044107B&REV_02\3&18D45AA6&0&FB: Intel(R) ICH9 Family SMBus Controller - 2930
PCI\VEN_8086&DEV_293C&SUBSYS_5044107B&REV_02\3&18D45AA6&0&D7: Intel(R) ICH9 Family USB2 Enhanced Host Controller - 293C
PCI\VEN_8086&DEV_29C1&SUBSYS_5044107B&REV_02\3&18D45AA6&0&08: Intel(R) G33/G31/P35/P31 Express Chipset PCI Express Root Port - 29C1
PCI\VEN_11C1&DEV_5811&SUBSYS_581111C1&REV_70\4&CD7FEEC&0&18F0: LSI 1394 OHCI Compliant Host Controller
PCI\VEN_8086&DEV_2934&SUBSYS_5044107B&REV_02\3&18D45AA6&0&E8: Intel(R) ICH9 Family USB Universal Host Controller - 2934
PCI\VEN_8086&DEV_293E&SUBSYS_7200107B&REV_02\3&18D45AA6&0&D8: High Definition Audio Controller
PCI\VEN_8086&DEV_29C4&SUBSYS_5044107B&REV_02\3&18D45AA6&0&18: PCI Simple Communications Controller
PCI\VEN_1283&DEV_8211&SUBSYS_82111283&REV_11\4&CD7FEEC&0&10F0: ITE IT8211 ATA/ATAPI Controller
PCI\VEN_8086&DEV_2935&SUBSYS_5044107B&REV_02\3&18D45AA6&0&E9: Intel(R) ICH9 Family USB Universal Host Controller - 2935
PCI\VEN_8086&DEV_2940&SUBSYS_29408086&REV_02\3&18D45AA6&0&E0: Intel(R) ICH9 Family PCI Express Root Port 1 - 2940
PCI\VEN_8086&DEV_10C0&SUBSYS_7200107B&REV_02\3&18D45AA6&0&C8: Intel(R) 82562V-2 10/100 Network Connection
PCI\VEN_8086&DEV_2936&SUBSYS_5044107B&REV_02\3&18D45AA6&0&EA: Intel(R) ICH9 Family USB Universal Host Controller - 2936
PCI\VEN_8086&DEV_2942&SUBSYS_29428086&REV_02\3&18D45AA6&0&E1: Intel(R) ICH9 Family PCI Express Root Port 2 - 2942
PCI\VEN_8086&DEV_244E&SUBSYS_5044107B&REV_92\3&18D45AA6&0&F0: Intel(R) 82801 PCI Bridge - 244E
PCI\VEN_8086&DEV_2937&SUBSYS_5044107B&REV_02\3&18D45AA6&0&D0: Intel(R) ICH9 Family USB Universal Host Controller - 2937
PCI\VEN_8086&DEV_2944&SUBSYS_29448086&REV_02\3&18D45AA6&0&E2: Intel(R) ICH9 Family PCI Express Root Port 3 - 2944
PCI\VEN_8086&DEV_2916&SUBSYS_5044107B&REV_02\3&18D45AA6&0&F8: Intel(R) ICH9R LPC Interface Controller - 2916
PCI\VEN_8086&DEV_2938&SUBSYS_5044107B&REV_02\3&18D45AA6&0&D1: Intel(R) ICH9 Family USB Universal Host Controller - 2938
PCI\VEN_8086&DEV_2946&SUBSYS_29468086&REV_02\3&18D45AA6&0&E3: Intel(R) ICH9 Family PCI Express Root Port 4 - 2946
PCI\VEN_8086&DEV_2920&SUBSYS_5044107B&REV_02\3&18D45AA6&0&FA: Standard Dual Channel PCI IDE Controller
PCI\VEN_8086&DEV_2939&SUBSYS_5044107B&REV_02\3&18D45AA6&0&D2: Intel(R) ICH9 Family USB Universal Host Controller - 2939
PCI\VEN_8086&DEV_2948&SUBSYS_29488086&REV_02\3&18D45AA6&0&E4: Intel(R) ICH9 Family PCI Express Root Port 5 - 2948
PCI\VEN_8086&DEV_2926&SUBSYS_5044107B&REV_02\3&18D45AA6&0&FD: Standard Dual Channel PCI IDE Controller
26 matching device(s) found.
 
=========== 
USB Devices 
=========== 
USB\VID_1058&PID_1100\57442D574D41535530333531383337        : USB Mass Storage Device
USB\ROOT_HUB20\4&34707ECE&0                                 : USB Root Hub
USB\VID_0424&PID_2504\5&325E8278&0&5                        : Generic USB Hub
USB\VID_1532&PID_000C\5&2FFCDBDE&0&1                        : USB Composite Device
USB\VID_1532&PID_000C&MI_00\6&1A590FA9&0&0000               : USB Input Device
USB\VID_046D&PID_C223\5&C4E6752&0&2                         : Generic USB Hub
USB\VID_1532&PID_000C&MI_01\6&1A590FA9&0&0001               : USB Input Device
USB\VID_046D&PID_C226\6&744DAC9&0&1                         : USB Composite Device
USBSTOR\DISK&VEN_&PROD_USB_FLASH_MEMORY&REV_5.00\0391077131C238C0&0: USB Flash Memory USB Device
USB\VID_046D&PID_C226&MI_00\7&1E363D62&0&0000               : USB Input Device
USB\VID_046D&PID_C226&MI_01\7&1E363D62&0&0001               : USB Input Device
USBSTOR\DISK&VEN_WD&PROD_3200AAV_EXTERNAL&REV_1.65\57442D574D41535530333531383337&0: WD 3200AAV External USB Device
USB\VID_046D&PID_C227\6&744DAC9&0&4                         : USB Input Device
USB\ROOT_HUB\4&10FD0E09&0                                   : USB Root Hub
USB\VID_0930&PID_6545\0391077131C238C0                      : USB Mass Storage Device
USB\ROOT_HUB\4&17F9E328&0                                   : USB Root Hub
USB\VID_0D8C&PID_000C\5&FD03DB6&0&2                         : USB Composite Device
USB\ROOT_HUB\4&1A8E1607&0                                   : USB Root Hub
USB\ROOT_HUB\4&1FC67650&0                                   : USB Root Hub
USB\VID_0D8C&PID_000C&MI_00\6&93EA89A&0&0000                : C-Media USB Audio Device   
USB\ROOT_HUB\4&2FFD5E7A&0                                   : USB Root Hub
USB\VID_0D8C&PID_000C&MI_03\6&93EA89A&0&0003                : USB Input Device
USB\ROOT_HUB\4&A572DDD&0                                    : USB Root Hub
USB\ROOT_HUB20\4&25341EED&0                                 : USB Root Hub
24 matching device(s) found.
 
============= 
Input Devices 
============= 
HID\VID_046D&PID_C226&MI_00\8&34A14EB1&0&0000               : HID Keyboard Device
HID\VID_046D&PID_C226&MI_01&COL01\8&10CA10EF&0&0000         : HID-compliant consumer control device
HID\VID_046D&PID_C226&MI_01&COL02\8&10CA10EF&0&0001         : HID-compliant device
HID\VID_046D&PID_C227&COL01\7&316A2B7A&0&0000               : HID Keyboard Device
HID\VID_046D&PID_C227&COL02\7&316A2B7A&0&0001               : HID-compliant device
HID\VID_0D8C&PID_000C&MI_03\7&DAFEC32&0&0000                : HID-compliant consumer control device
HID\VID_1532&PID_000C&MI_00\7&3239F985&0&0000               : HID-compliant mouse
HID\VID_1532&PID_000C&MI_01\7&E62BBC3&0&0000                : HID Keyboard Device
8 matching device(s) found.
 
============ 
ACPI Devices 
============ 
ACPI\PNP0000\4&2F7D9112&0                                   : Programmable interrupt controller
ACPI\PNP0003\3&18D45AA6&0                                   : Advanced programmable interrupt controller
ACPI\PNP0100\4&2F7D9112&0                                   : System timer
ACPI\PNP0200\4&2F7D9112&0                                   : Direct memory access controller
ACPI\FIXEDBUTTON\2&DABA3FF&1                                : ACPI Fixed Feature Button
ACPI\PNP0800\4&2F7D9112&0                                   : System speaker
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15_-_INTEL(R)_CORE(TM)2_QUAD_CPU___________@_2.40GHZ\_1: Intel(R) Core(TM)2 Quad CPU           @ 2.40GHz
ACPI\PNP0A03\2&DABA3FF&1                                    : PCI bus
ACPI\PNP0A06\3&473F1A46&0                                   : Extended IO Bus
ACPI\PNP0B00\4&2F7D9112&0                                   : System CMOS/real time clock
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15_-_INTEL(R)_CORE(TM)2_QUAD_CPU___________@_2.40GHZ\_2: Intel(R) Core(TM)2 Quad CPU           @ 2.40GHz
ACPI\PNP0C02\1                                              : Motherboard resources
ACPI\PNP0C02\2                                              : Motherboard resources
ACPI\PNP0C02\3                                              : Motherboard resources
ACPI\PNP0C04\4&2F7D9112&0                                   : Numeric data processor
ACPI\PNP0C0E\2&DABA3FF&1                                    : ACPI Sleep Button
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15_-_INTEL(R)_CORE(TM)2_QUAD_CPU___________@_2.40GHZ\_3: Intel(R) Core(TM)2 Quad CPU           @ 2.40GHz
ROOT\ACPI_HAL\0000                                          : ACPI x86-based PC
ACPI\PNPA000\4&5D18F2DF&0                                   : AZDWOI3P IDE Controller
ACPI_HAL\PNP0C08\0                                          : Microsoft ACPI-Compliant System
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_15_-_INTEL(R)_CORE(TM)2_QUAD_CPU___________@_2.40GHZ\_4: Intel(R) Core(TM)2 Quad CPU           @ 2.40GHz
21 matching device(s) found.
 
============ 
 HDA Audio 
============ 
HDAUDIO\FUNC_01&VEN_8384&DEV_7626&SUBSYS_107B7200&REV_1002\4&24856F4C&0&0201: High Definition Audio Device
1 matching device(s) found.
 
============ 
RAID Devices 
============ 
PCI\VEN_1283&DEV_8211&SUBSYS_82111283&REV_11\4&CD7FEEC&0&10F0
    Name: ITE IT8211 ATA/ATAPI Controller
    Hardware ID's:
        PCI\VEN_1283&DEV_8211&SUBSYS_82111283&REV_11
        PCI\VEN_1283&DEV_8211&SUBSYS_82111283
        PCI\VEN_1283&DEV_8211&CC_018000
        PCI\VEN_1283&DEV_8211&CC_0180
    Compatible ID's:
        PCI\VEN_1283&DEV_8211&REV_11
        PCI\VEN_1283&DEV_8211
        PCI\VEN_1283&CC_018000
        PCI\VEN_1283&CC_0180
        PCI\VEN_1283
        PCI\CC_018000
        PCI\CC_0180
PCI\VEN_8086&DEV_2920&SUBSYS_5044107B&REV_02\3&18D45AA6&0&FA
    Name: Standard Dual Channel PCI IDE Controller
    Hardware ID's:
        PCI\VEN_8086&DEV_2920&SUBSYS_5044107B&REV_02
        PCI\VEN_8086&DEV_2920&SUBSYS_5044107B
        PCI\VEN_8086&DEV_2920&CC_01018F
        PCI\VEN_8086&DEV_2920&CC_0101
    Compatible ID's:
        PCI\VEN_8086&DEV_2920&REV_02
        PCI\VEN_8086&DEV_2920
        PCI\VEN_8086&CC_01018F
        PCI\VEN_8086&CC_0101
        PCI\VEN_8086
        PCI\CC_01018F
        PCI\CC_0101
PCI\VEN_8086&DEV_2926&SUBSYS_5044107B&REV_02\3&18D45AA6&0&FD
    Name: Standard Dual Channel PCI IDE Controller
    Hardware ID's:
        PCI\VEN_8086&DEV_2926&SUBSYS_5044107B&REV_02
        PCI\VEN_8086&DEV_2926&SUBSYS_5044107B
        PCI\VEN_8086&DEV_2926&CC_010185
        PCI\VEN_8086&DEV_2926&CC_0101
    Compatible ID's:
        PCI\VEN_8086&DEV_2926&REV_02
        PCI\VEN_8086&DEV_2926
        PCI\VEN_8086&CC_010185
        PCI\VEN_8086&CC_0101
        PCI\VEN_8086
        PCI\CC_010185
        PCI\CC_0101
3 matching device(s) found.

hopefully i finally managed to cover my situation well enough, sorry guys haha

Re: cd/dvd device driver missing on install

Ok, you can see the motherboard type with programs like everest and sisoft sandra etc.

And adding drivers for sata/raid etc you need to slipstream the driver into BOOT.WIM , and INSTALL.WIM or it wont work.
And as for the driver, i will look into this if i can update it.

And contare, please try to use the edit button on the forum more often. smile

And @ overflow , yes ibexide.inf contains that hwid