Topic: xp pro sp3: sysprep stops and does not shutdown the computer [solved]

i haven't done this in almost 2 years but i do remember my last few successful images using driverpacks.  so now i'm trying to do it one more time but sysprep stops about 15 minutes into the process during the "Sysprep is working..." window.  i open up task manager and sysprep.exe is not in the processes.  after waiting a few minutes and still no shutdown, i manually reboot the computer just to test it and i don't get any mini-setup.  i don't get any text-mode or gui-mode driver detection, network detection, domain authentication.  i do get the message "xp is preparing computer for first time use", but otherwise it is not joined to the domain once it reaches the login screen.  at least i don't get any bsod, especially the dreaded 0x7b. nor do i get the black screen of death (pic hal).

The following is a brief summary of my template computer preparation:
- machine is on a fully patched vmware esxi 5 update 1 box
- 2-core cpu, 512mb ram, 15gb ide
- xp pro w/sp3 vl iso installed using vlk
- machine never on domain
- no windows updates nor software as i'm only testing driverpacks
- wga never installed
- manually downloaded latest driver packs
- have pared down the mass storage drivers after each unsuccessful test to just \d\m\i*
- disabled system restore, page files, and hibernation
- sysprep cab files are sp3
- using spdrvscan132- using the older hwids.cmd rather than findhwids.exe
- running sysprep -bmsd after hwids
- sysprep.inf file is the same file as it's been for the past 3 years
- > sysprep -mini -pnp -quiet -reseal
- alternately used -forceshutdown with the same results

[update] Solved:

after eliminating the driverpacks one-by-one, the problem is with the intel mass storage drivers \D\M\I2 and \D\M\I3 with hwids.cmd.  rather than deleting those folders, i moved them to an alternate location and modified spdrvscn and sysprep.inf as follows:

> spdrvscn132 /p %systemdrive%\sysprep\d /d %systemdrive%\sysprep\op #OemPnPDrivers


FWIW, i don't know if all this is necessary or whether it makes a difference.  simply removing D\M\I2 and D\M\I3 should work

Last edited by ringonian (2012-04-04 02:38:10)