Re: Intel 945GM + Mass 10.06 = Problem

I know it's frustrating, but you're providing valuable testing info, and your posts ARE making a difference.

Re: Intel 945GM + Mass 10.06 = Problem

Thankyou smarte_pants smile

Im happy to help you guys but honestly im really pissed at this crap and im bout to give up very soon....

Re: Intel 945GM + Mass 10.06 = Problem

OK, I'm building one more test pack for you.  Stand by...

Re: Intel 945GM + Mass 10.06 = Problem

Test#4: http://www.mediafire.com/file/z7p3551zl … 10test4.7z
Test#5: http://www.mediafire.com/file/cafls6607 … 10test5.7z

Re: Intel 945GM + Mass 10.06 = Problem

Thanks pants:)

Ill try them tomorrow beacuse its 9:02 PM here in sweden.

Re: Intel 945GM + Mass 10.06 = Problem

Sofar test4 is actually working properly woho:)!

Ill now try slipstreaming the other driverpacks and try again.

Re: Intel 945GM + Mass 10.06 = Problem

Awesome news.  Now I know what to fix.
See, this is how stuff gets fixed.  We don't know there's a problem unless someone reports it AND helps test the fixes.
You just made the DriverPacks BETTER!  Well done! smile

Re: Intel 945GM + Mass 10.06 = Problem

mr_smartepants wrote:

Awesome news.  Now I know what to fix.
See, this is how stuff gets fixed.  We don't know there's a problem unless someone reports it AND helps test the fixes.
You just made the DriverPacks BETTER!  Well done! smile

Haha i feel much better now:)
I was abit surprised it found the hdd but oh so good hehe. Im glad i can help you!

Now i just have to make ut completely unattended but i can do that myself.

Re: Intel 945GM + Mass 10.06 = Problem

tcntad wrote:

Sofar test4 is actually working properly woho:)!

Ill now try slipstreaming the other driverpacks and try again.

I was having the same issues as you. I haven't tested the others, but I can confirm that test4 works fine on my end as well.

Last edited by dumpydooby (2010-10-18 03:37:28)

Re: Intel 945GM + Mass 10.06 = Problem

Well that's odd.  test#4 also commented out some competing HWIDs (sections [T], [L6] & [L1] )
Your HWID (PCI\VEN_8086&DEV_27C5&CC_0106) was the only one moved to section [I2], the rest stayed at [I3].
Hmmm.
@Dumpydooby, can you comment/delete sections [T], [L6] & [L1] from the nightly 10.10.03 .ini and retest?

Re: Intel 945GM + Mass 10.06 = Problem

Just commenting out [T] works. I did not comment out [L6] and [L1]. The drive shows up in textmode. I'll edit this post if there are any issues post-installation.



Here are my laptop HWIDs again.

The relevant one:

PCI\VEN_8086&DEV_27C5&CC_0106

The full list:

=========== 
PCI Devices 
=========== 
PCI\VEN_1002&DEV_7145&SUBSYS_0281107B&REV_00\4&31B7BFB9&0&0008: ATI Mobility Radeon X1400
PCI\VEN_104C&DEV_8039&SUBSYS_0281107B&REV_00\4&6B16D5B&0&48F0: Generic CardBus Controller
PCI\VEN_104C&DEV_803A&SUBSYS_0281107B&REV_00\4&6B16D5B&0&49F0: Texas Instruments OHCI Compliant IEEE 1394 Host Controller
PCI\VEN_104C&DEV_803B&SUBSYS_0281107B&REV_00\4&6B16D5B&0&4AF0: Texas Instruments PCIxx12 Integrated FlashMedia Controller
PCI\VEN_8086&DEV_2448&SUBSYS_00000000&REV_E2\3&B1BFB68&0&F0 : Intel(R) 82801 PCI Bridge - 2448
PCI\VEN_8086&DEV_27A0&SUBSYS_00000000&REV_03\3&B1BFB68&0&00 : Mobile Intel(R) 945GM/GU/PM/GMS/940GML/943GML and Intel(R) 945GT Express Processor to DRAM Controller - 27A0
PCI\VEN_8086&DEV_27A1&SUBSYS_00000000&REV_03\3&B1BFB68&0&08 : Mobile Intel(R) 945GM/GU/PM/GMS/940GML/943GML and Intel(R) 945GT Express PCI Express Root Port - 27A1
PCI\VEN_8086&DEV_27B9&SUBSYS_00000000&REV_02\3&B1BFB68&0&F8 : Intel(R) 82801GBM (ICH7-M/U) LPC Interface Controller - 27B9
PCI\VEN_8086&DEV_27C5&SUBSYS_0281107B&REV_02\3&B1BFB68&0&FA : Intel(R) ICH7M/MDH SATA AHCI Controller
PCI\VEN_8086&DEV_27C8&SUBSYS_0281107B&REV_02\3&B1BFB68&0&E8 : Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27C8
PCI\VEN_8086&DEV_27C9&SUBSYS_0281107B&REV_02\3&B1BFB68&0&E9 : Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27C9
PCI\VEN_8086&DEV_27CA&SUBSYS_0281107B&REV_02\3&B1BFB68&0&EA : Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27CA
PCI\VEN_8086&DEV_27CB&SUBSYS_0281107B&REV_02\3&B1BFB68&0&EB : Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27CB
PCI\VEN_8086&DEV_27CC&SUBSYS_0281107B&REV_02\3&B1BFB68&0&EF : Intel(R) 82801G (ICH7 Family) USB2 Enhanced Host Controller - 27CC
PCI\VEN_8086&DEV_27D0&SUBSYS_00000000&REV_02\3&B1BFB68&0&E0 : Intel(R) 82801G (ICH7 Family) PCI Express Root Port - 27D0
PCI\VEN_8086&DEV_27D2&SUBSYS_00000000&REV_02\3&B1BFB68&0&E1 : Intel(R) 82801G (ICH7 Family) PCI Express Root Port - 27D2
PCI\VEN_8086&DEV_27D8&SUBSYS_0281107B&REV_02\3&B1BFB68&0&D8 : Microsoft UAA Bus Driver for High Definition Audio
PCI\VEN_8086&DEV_27DA&SUBSYS_0281107B&REV_02\3&B1BFB68&0&FB : Intel(R) 82801G (ICH7 Family) SMBus Controller - 27DA
PCI\VEN_8086&DEV_27DF&SUBSYS_0281107B&REV_02\3&B1BFB68&0&F9 : Intel(R) 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF
PCI\VEN_8086&DEV_4222&SUBSYS_10008086&REV_02\4&20975680&0&00E1: Intel(R) PRO/Wireless 3945ABG Network Connection
20 matching device(s) found.
 
=========== 
USB Devices 
=========== 
USB\ROOT_HUB\4&109ACDC&0                                    : USB Root Hub
USB\ROOT_HUB\4&13A4581B&0                                   : USB Root Hub
USB\ROOT_HUB\4&21A2F64&0                                    : USB Root Hub
USB\ROOT_HUB\4&2B1A4E2C&0                                   : USB Root Hub
USB\ROOT_HUB20\4&9F996B0&0                                  : USB Root Hub
USB\VID_13FE&PID_1E00\07A30F01DE172B62                      : USB Mass Storage Device
USBSTOR\DISK&VEN_&PROD_PATRIOT_MEMORY&REV_PMAP\07A30F01DE172B62&0: Patriot Memory USB Device
7 matching device(s) found.
 
============= 
Input Devices 
============= 
No matching devices found.
 
============ 
ACPI Devices 
============ 
ACPI\ACPI0003\2&DABA3FF&0                                   : Microsoft AC Adapter
ACPI\FIXEDBUTTON\2&DABA3FF&0                                : ACPI Fixed Feature Button
ACPI\FPI2004\5&1907E21B&0
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_14\_0                : Genuine Intel(R) CPU           T2400  @ 1.83GHz
ACPI\GENUINEINTEL_-_X86_FAMILY_6_MODEL_14\_1                : Genuine Intel(R) CPU           T2400  @ 1.83GHz
ACPI\MSTABLETPCBUTTONS\3&B1BFB68&0
ACPI\PNP0000\4&38462492&0                                   : Programmable interrupt controller
ACPI\PNP0100\4&38462492&0                                   : System timer
ACPI\PNP0200\4&38462492&0                                   : Direct memory access controller
ACPI\PNP0303\4&38462492&0                                   : Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
ACPI\PNP0A05\4&38462492&0                                   : Generic Bus
ACPI\PNP0A08\2&DABA3FF&0                                    : PCI bus
ACPI\PNP0B00\4&38462492&0                                   : System CMOS/real time clock
ACPI\PNP0C02\1                                              : Motherboard resources
ACPI\PNP0C02\2                                              : Motherboard resources
ACPI\PNP0C04\4&38462492&0                                   : Numeric data processor
ACPI\PNP0C09\1                                              : Microsoft ACPI-Compliant Embedded Controller
ACPI\PNP0C0A\1                                              : Microsoft ACPI-Compliant Control Method Battery
ACPI\PNP0C0A\2                                              : Microsoft ACPI-Compliant Control Method Battery
ACPI\PNP0C0C\2&DABA3FF&0                                    : ACPI Power Button
ACPI\PNP0C0D\2&DABA3FF&0                                    : ACPI Lid
ACPI\PNP0C0E\2&DABA3FF&0                                    : ACPI Sleep Button
ACPI\SYN0403\4&38462492&0                                   : PS/2 Compatible Mouse
ACPI\THERMALZONE\TZ00                                       : ACPI Thermal Zone
ACPI_HAL\PNP0C08\0                                          : Microsoft ACPI-Compliant System
ROOT\ACPI_HAL\0000                                          : ACPI Multiprocessor PC
26 matching device(s) found.
 
============ 
 HDA Audio 
============ 
HDAUDIO\FUNC_01&VEN_8384&DEV_7634&SUBSYS_107B0281&REV_1001\4&36A4D72A&0&0001: SigmaTel High Definition Audio CODEC
HDAUDIO\FUNC_02&VEN_1057&DEV_3057&SUBSYS_00010001&REV_1001\4&36A4D72A&0&0101: Modem Device on High Definition Audio Bus
2 matching device(s) found.
 
============ 
RAID Devices 
============ 
PCI\VEN_104C&DEV_803B&SUBSYS_0281107B&REV_00\4&6B16D5B&0&4AF0
    Name: Texas Instruments PCIxx12 Integrated FlashMedia Controller
    Hardware ID's:
        PCI\VEN_104C&DEV_803B&SUBSYS_0281107B&REV_00
        PCI\VEN_104C&DEV_803B&SUBSYS_0281107B
        PCI\VEN_104C&DEV_803B&CC_018000
        PCI\VEN_104C&DEV_803B&CC_0180
    Compatible ID's:
        PCI\VEN_104C&DEV_803B&REV_00
        PCI\VEN_104C&DEV_803B
        PCI\VEN_104C&CC_018000
        PCI\VEN_104C&CC_0180
        PCI\VEN_104C
        PCI\CC_018000
        PCI\CC_0180
PCI\VEN_8086&DEV_27C5&SUBSYS_0281107B&REV_02\3&B1BFB68&0&FA
    Name: Intel(R) ICH7M/MDH SATA AHCI Controller
    Hardware ID's:
        PCI\VEN_8086&DEV_27C5&SUBSYS_0281107B&REV_02
        PCI\VEN_8086&DEV_27C5&SUBSYS_0281107B
        PCI\VEN_8086&DEV_27C5&CC_010601
        PCI\VEN_8086&DEV_27C5&CC_0106
    Compatible ID's:
        PCI\VEN_8086&DEV_27C5&REV_02
        PCI\VEN_8086&DEV_27C5
        PCI\VEN_8086&CC_010601
        PCI\VEN_8086&CC_0106
        PCI\VEN_8086
        PCI\CC_010601
        PCI\CC_0106
PCI\VEN_8086&DEV_27DF&SUBSYS_0281107B&REV_02\3&B1BFB68&0&F9
    Name: Intel(R) 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF
    Hardware ID's:
        PCI\VEN_8086&DEV_27DF&SUBSYS_0281107B&REV_02
        PCI\VEN_8086&DEV_27DF&SUBSYS_0281107B
        PCI\VEN_8086&DEV_27DF&CC_01018A
        PCI\VEN_8086&DEV_27DF&CC_0101
    Compatible ID's:
        PCI\VEN_8086&DEV_27DF&REV_02
        PCI\VEN_8086&DEV_27DF
        PCI\VEN_8086&CC_01018A
        PCI\VEN_8086&CC_0101
        PCI\VEN_8086
        PCI\CC_01018A
        PCI\CC_0101
3 matching device(s) found.

Last edited by dumpydooby (2010-10-18 09:51:19)

Re: Intel 945GM + Mass 10.06 = Problem

I built a pack that works with [T] enabled. It is based on DPM101003.

I duplicated the I4 directory and renamed it to IC.

Then I added this right before [T] in the INI file:
(note: I left the [I4] entry alone!)

; This section has to be before [T]
[IC]
; 8.9.0.1023 / 9.6.0.1014
ms_count=1
ms_1_deviceName="Intel ICH7 SATA AHCI/RAID"
ms_1_tag="iastor4"
ms_1_sysFile="iastor4.sys"
ms_1_hwids="PCI\VEN_8086&DEV_27C5&SUBSYS_0281107B"
ms_1_isBusExtender=false
ms_1_exc_disableIfOS="w2k"

I'm not sure how nicely that will play with everything else, but it worked for me. The result is duplicated content in the directory structure, but that shouldn't affect compression at all since 7-zip will merely count it twice.

Pack I created: http://xp.xpdnc.org/temp/DP_MassStorage … 101004f.7z
md5: c5ad244c5d5e49e0a27f46dc123db107

(by the way, I'm not sure if this will work with the thread-starter's device; i would not expect it to work without first adding his device to the INI)

Re: Intel 945GM + Mass 10.06 = Problem

Yeah, I figured that would be the case. [T] has been in there since last year, but it has caused problems for others as well.
The key here is that yours DOES work with [I4], but the install is somehow getting confused and using [T] even though the HWID is not a match.

Re: Intel 945GM + Mass 10.06 = Problem

Curse you ricktendo64! mad

Re: Intel 945GM + Mass 10.06 = Problem

Hmm, just ran it again on the laptop. It hung at T-34 overnight. I rebooted this morning so setup could finish and now it's in a 7B BSOD loop. When it worked previously, I had only integrated CPU, Chipset, and MassStorage. Tentatively, I would say that adding the rest causes this problem, but it could be an anomaly. I'll restart from scratch and try again.

edit--
After two runs, I confirmed it happens every time if I include all packs. I tried a run with CPU, Chipset, MassStorage, LAN and WLAN, and it still happened. I'll try just including CPU, Chipset, and MassStorage again to see if it works as expected. If it does, then I'll work on narrowing down which networking driver pack is incompatible. I did notice that pnplog.txt's last entry was the integrated Texas Instruments firewire adapter. I tried to see if I could disable that in the BIOS, but that option isn't available.

edit 2--
That was also all on the same burn. Perhaps it was a bad one. I'll do an md5 check on it.

Last edited by dumpydooby (2010-10-19 04:50:42)

Re: Intel 945GM + Mass 10.06 = Problem

Please try this test pack: http://www.mediafire.com/file/3fa43340z … _101006.7z