Topic: TrackPad PS/2 Interfacing

Whilst shopping a few days ago, i stumbled across an old Kensington Webracer.
     image from: … Racer.html

It's drivers and applications CD indicated that it was meant for Windows 95 and 98.  I purchased it anyway for $10 CDN, considering the fact that many such devices will default to working as a regular mouse.

After arriving home i tested it as such and it worked as expected.  It worked like a mouse, yet scrolling, tap-to-click, nor the Web-buttons worked.  I avoided trying the included software as i had no confidence on it's ability to work with NT5.

I found Kensington's support site, yet the product was unlisted.  I found their ftp and wasted a couple of hours tracking down and testing any relevant MouseWare software.  The latest version that i could find that seemed to support that product and NT5 was "MouseWorks-5_61.exe".  Contradicting what the name implied, it didn't work.  The software could not detect the WebRacer despite the appropriate driver being successfully installed.

I dismantled the troublesome device and discovered a Synaptics T1004-based TrackPad.  My enthusiasm was once again buoyed.  After a few searches on the "interweb", i stumbled acrosse the following two sites. … aging.html … o-ps2.html

It took a couple of hours to isolate the PS/2 cable-end, four main buttons and the TrackPad ribbon connector on the WebRacer's mainboard.  Then i used some small hookup wire to complete the connections according to the Synaptics PS/2 Interfacing guide "ACF126.pdf" linked in one of the aforementioned sites.  Using my Digital Multimeter, i verified all connections.

Unfortunately, after a couple of test runs it became apparent that it was no longer functional.  After double-checking all connections, it became apparent that the two pull-up resistors were missing from the PS/2 Data and Clock lines.  I found a pair of suitable resistors and eagerly looked forward to success.

Regrettably that was not the case.  Windows did detect it as a standard PS/2 Mouse through a KVM, yet non-functional even with "Synaptics_Driver_v10_1_8_XP32.exe" software installed.  It was starting to look like a door-stop.  I tried once more by directly plugging it in to PS/2, yet this time Windows wouldn't detect it at all.

After reviewing the literature it would appear that the particular TrackPad model in question, that is the "TM41PDJK134-2", was a custom part and probably has custom firmware included.
I found a few more spare TrackPads and realized that they too were custom parts.  They didn't work either.

Failure sucks!  Yet as in baseball, one must learn from both one's failures as well as one's successes.  Anyone familiar with baseball will know that failure comes far more often than success.

I write this should anyone else attempt this kind of interfacing in the hope that they will succeed where i had failed.

Last edited by TechDud (2013-06-24 05:53:37)