Topic: D-link DWA-126

D-Link DWA-126 (wireless (radio)) Wireless 150 USB2.0 802.11n - USB \ Vid_07d1 & Pid_3a10 & Rev_0108

Erroneously defined as a device: High-Power Wireless N USB adapter 150
Drivers are installed but not working
working driver - http://depositfiles.com/files/erxdd00ak

Worked on Windows 8.1 Pro

Re: D-link DWA-126

say, that driver is "DriverVer=09/30/2009,7.7.0.65"
  have you tried "DriverVer=09/30/2010,7.7.0.98" avail here --> http://forum.driverpacks.net/viewtopic. … 681#p44681 hmm  edit: updated link

Oh Snap!
nevermind; how 'bout "DriverVer=07/28/2011,7.7.0.102" instead! cool cool
http://ftp.dlink.ru/pub/Wireless/DWA-12 … 101B03.rar just released oct28 2011; includes the following hwid's (as the previous, yet not like the one linked in the post above):

%ATHER.DeviceDesc.9271% = ATHER_DEV_9271.ndi,     USB\VID_0CF3&PID_9271
%ATHER.DeviceDesc.7010% = ATHER_DEV_7010.ndi,     USB\VID_0CF3&PID_7010
%ATHER.DeviceDesc.7015% = ATHER_DEV_7015.ndi,     USB\VID_0CF3&PID_7015
%ATHER.DeviceDesc.1006% = ATHER_DEV_1006.ndi,     USB\VID_0CF3&PID_1006

[NETGEAR]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; Netgear
%NTGR.DeviceDesc.9030%  = NTGR_DEV_9030.ndi,      USB\VID_0846&PID_9030
%NTGR.DeviceDesc.9018%  = NTGR_DEV_9018.ndi,      USB\VID_0846&PID_9018

[DLINK]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; DLINK
%DLINK.DeviceDesc.3A10% = DLINK_DEV_3A10.ndi,     USB\VID_07D1&PID_3A10

[AZUREWAVE]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; AZUREWAVE
%AZWV.DeviceDesc.3327%  = AZWV_DEV_3327.ndi,      USB\VID_13D3&PID_3327
%AZWV.DeviceDesc.3328%  = AZWV_DEV_3328.ndi,      USB\VID_13D3&PID_3328
%AZWV.DeviceDesc.3346%  = AZWV_DEV_3346.ndi,      USB\VID_13D3&PID_3346
%AZWV.DeviceDesc.3348%  = AZWV_DEV_3348.ndi,      USB\VID_13D3&PID_3348
%AZWV.DeviceDesc.3349%  = AZWV_DEV_3349.ndi,      USB\VID_13D3&PID_3349
%AZWV.DeviceDesc.3350%  = AZWV_DEV_3350.ndi,      USB\VID_13D3&PID_3350

[LITEON]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; LITEON
%ATHER.DeviceDesc.9271% = ATHER_DEV_9271.ndi,     USB\VID_04CA&PID_4605

[SMC]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; SMC
%SMC.DeviceDesc.A704%   = SMC_DEV_A704.ndi,       USB\VID_083A&PID_A704

[VIA]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; VIA
%VIA.DeviceDesc.3801%   = ATHER_DEV_9271.ndi,     USB\VID_040D&PID_3801

[VERIZON]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
; Verizon
%VRZN.DeviceDesc.1200%  = ATHER_DEV_7015.ndi,     USB\VID_1668&PID_1200

If it works for you, SamLab, perhaps this driver could serve as a candidate to replace the 'generic' Atheros AR701x & AR9271 drivers. big_smile
I could be wrong; this could be a HW-specific driver.

edit: unlike the posted driver(v7.7.0.65 inf, v7.7.0.75 sys), this one has valid WHQL SHA1 sigs & it has perhaps an über util with it?
hold up, the .sys file has an invalid sig(edit: like other .sys for this HW, the file has no Certificate Table in the Data Directories), so it shouldn't pass WHQL.  The inf file is valid.

the util is from 2009, v4.32.124; perhaps not so über, after all.  At least it should prove an upgrade for your HW, SamLab.
updated util here --> http://ftp.dlink.ru/pub/Wireless/DWA-126/Drivers/1.01/

I would suspect that one of the "Atheros Client" utilities should function with products based on the underlying chip.

Last edited by TechDud (2011-11-15 07:44:45)

Re: D-link DWA-126

by any chance would you happen to have a "Xbox360 Wireless N Networking Adapter [Atheros AR7010]" with the black plastic casing (or a Sony UWA-BR100, Panasonic N5HBZ0000055, Ubiquiti WiFiStation) kicking around?  any of these drivers could be a candidate for it. (same underlying chip)

edit:  can anyone confirm the WHQL status of the athuw.sys included with any AR701x/AR9271 driver by actually looking at the file-name in Device Manager?

Last edited by TechDud (2011-11-15 06:46:07)

Re: D-link DWA-126

found the driver for Atheros AR701x/AR9271 USB WiFi adapters from ECS here (win-all with utility) --> http://download.ecsusa.com/dlfileecs/dr … theros.zip big_smile
(XP v7.7.0.102; Vista v8.8.0.84; w7 v2.0.0.62) once again, there are no certificates included in any of the .sys files; the .Inf's are WHQL.  The utility is from mid-2009.

edit: w7 v9.2.0.19 referenced elsewhere is newer, yet contains fewer HWID's

%ATHER.DeviceDesc.9271% = ATHER_DEV_9271_SS.ndi,  USB\VID_0CF3&PID_9271&REV_0108&SS

what are the odds that your adapter supports SelectiveSuspend, SamLab?

Say, a valid certificate is in the security catalog; does that make a difference?  Otherwise, i have no idea how any of the 64bit drivers could work without Driver Signature Enforcement disabled.

This generic utility is recent (Mar 2011) & for XP (ACU installed from XpUtl; vista is referenced internally, so possibly vista-7 - AWiCDiag) --> http://support1.toshiba-tro.de/tools/up … 001940.zip

Here's a AR701x/AR9271 Win-All composite pack reconstituted for testing:  http://www.mediafire.com/file/94tprkx46 … 0WiFi-N.7z big_smile

Last edited by TechDud (2011-11-15 10:15:08)

Re: D-link DWA-126

...still waiting for SamLab to report back.  Nothing implemented for DriverPack WLAN 12.02 yet.