Try to delete the QSC folder in your dbase install folder.
Run dbase without quick stream cache, and disable KTD

This fixed it for me.

I first tought this was some swichless install, so i tried to slipdtream all my post sp2 update, softwares and other stuff with nlite, then installed this test cd in vmware.  ?t worked, i then sliptream the my driverpacks to this cd, but deleted the QSC folder before i process it, just to accelerate my troubleshouting process i decided to disable ktd also(i dont realy need this stuff).  And It it work.  I then paste my $oem (switchless install) folder to my cd and corrected my winnt.sif file.  Still work.

Must be the QSC folder or KTD. 

But i bet on QSC, since you say disabeling ktd didnt do the trick...
Does not make much sense but h*ll, i have no god damn desktop.ini on reboot.

For those who are stuck with a desktop.ini startup and do not want to slipstream again:
RUN msconfig and uncheck desktop under stratup. This will "hide" the problem.

Good luck